Bug 171524 - wakeup stopped working on ibm t43 between 1526 and 1532 kernel
wakeup stopped working on ibm t43 between 1526 and 1532 kernel
Status: CLOSED DUPLICATE of bug 169201
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-22 03:16 EDT by jonathan baron
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-17 13:36:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jonathan baron 2005-10-22 03:16:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050918 Firefox/1.6a1

Description of problem:
Wakeup using mem in /sys/power/state worked in the 1526
kernel for suspend.  It takes a long time to wake up.
When I updated the kernel, it stopped working.  The suspend
sounded different, as if the disk stopped.  Wakeup was
very fast, but, after the supposed wakeup, nothing worked.
I didn't have time to search thoroughly for this bug under
all possible headings. Sorry.  I did save a big chunk of
/var/log/messages, available on request by Monday if not
before.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.
2.
3.
  

Additional info:

baron@psych.upenn.edu
Comment 1 Dave Jones 2005-11-10 14:50:26 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 2 jonathan baron 2005-11-10 15:27:08 EST
The new 1.1637 kernel works in the T43.  Just as good as 1.1526 (although
the screen looks a little different, but it is just as fast).  Yay!
Thus, I think this particular bug should be marked fixed, but I
don't think I have the power to do that.
Comment 3 jonathan baron 2005-11-10 15:40:23 EST
I spoke too soon.  After the computer resumed, and I did a few
things to test it, everything "froze" and I had to reboot.
(This may have taken a few minutes.)
I'm going to try again, but, once again, I offer to send whatever
logs might be helpful.
Comment 4 jonathan baron 2005-12-01 06:09:51 EST
I think this bug MAY be a duplicate of
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169201
and there is further discussion of the issue at
http://www.thinkwiki.org/wiki/Problems_with_SATA_and_Linux
including a patch (which I have not tried).

The only reason I think this bug may not be a duplicate is
that suspend/resume actually works for me with the
2.6.13-1.1526_FC4 kernel (which I'm still using).  According
to all these other things, it shouldn't work at all.
Comment 5 jonathan baron 2005-12-14 08:18:46 EST
The 2.6.14-1.1653_FC4 kernel is a little better.  On resuming after suspend,
the computer (IBM T43) took about 30 sec to freeze up, but the pointer still
worked.  That is, it moved around on the screen, but clicking didn't do
anything.  The problem was not just X, since I could also not connect to
the computer through the wireless connection.
Comment 6 Paul W. Frields 2005-12-17 13:36:07 EST
All of this is expected behavior for the SATA resume problem.  This bug is
indeed a duplicate of bug 169201.

*** This bug has been marked as a duplicate of 169201 ***

Note You need to log in before you can comment on or make changes to this bug.