Bug 1715384 - did: dependency is missing on fedora 30
Summary: did: dependency is missing on fedora 30
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: did
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Šplíchal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-30 08:50 UTC by Jan Kepler
Modified: 2019-12-02 12:23 UTC (History)
3 users (show)

Fixed In Version: did-0.15-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-02 12:23:03 UTC


Attachments (Terms of Use)

Description Jan Kepler 2019-05-30 08:50:27 UTC
Description of problem:
~~~~~~~~~~~~~~~~~~~~~~~
   'python2-requests-gssapi' did dependency missing on fedora30

Version-Release:
~~~~~~~~~~~~~~~~
   did-0.12-3.fc30.noarch


Steps to Reproduce:
~~~~~~~~~~~~~~~~~~~
   $ sudo dnf install did


Actual results:
~~~~~~~~~~~~~~~
   Last metadata expiration check: 0:43:23 ago on Thu 30 May 2019 09:37:48 AM CEST.
   Error: 
    Problem: conflicting requests
     - nothing provides python2-requests-gssapi needed by did-0.12-3.fc30.noarch
   (try to add '--skip-broken' to skip uninstallable packages)

Comment 1 Fedora Update System 2019-10-29 08:25:00 UTC
FEDORA-2019-ee8456ee9d has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ee8456ee9d

Comment 2 Fedora Update System 2019-10-29 08:25:01 UTC
FEDORA-2019-0365ac27ff has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0365ac27ff

Comment 3 Fedora Update System 2019-10-29 08:25:10 UTC
FEDORA-2019-0c2e93b669 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-0c2e93b669

Comment 4 Petr Šplíchal 2019-10-29 08:29:04 UTC
Should be fixed in the latest update in which did has been migrated to python3.
Fresh packages also available in the copr repo:
https://copr.fedorainfracloud.org/coprs/psss/did/

Comment 5 Fedora Update System 2019-10-30 01:19:30 UTC
did-0.14-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-0365ac27ff

Comment 6 Petr Šplíchal 2019-12-02 12:21:30 UTC
Fix verified with did-0.15-1.fc30:

# dnf install -y did
Last metadata expiration check: 0:02:16 ago on Po 2. prosince 2019, 07:16:04 EST.
Dependencies resolved.
======================================================================
 Package                   Arch     Version           Repo       Size
======================================================================
Installing:
 did                       noarch   0.15-1.fc30       updates   118 k
Installing dependencies:
 python3-bugzilla          noarch   2.3.0-1.fc30      updates    89 k
 python3-httplib2          noarch   0.11.3-6.fc30     fedora    115 k
 python3-requests-gssapi   noarch   1.0.0-6.fc30      fedora     24 k

Transaction Summary
======================================================================
Install  4 Packages

...

Installed:
  did-0.15-1.fc30.noarch                                              
  python3-bugzilla-2.3.0-1.fc30.noarch                                
  python3-httplib2-0.11.3-6.fc30.noarch                               
  python3-requests-gssapi-1.0.0-6.fc30.noarch                         

Complete!

Comment 7 Petr Šplíchal 2019-12-02 12:23:03 UTC
Latest did package already included in the stable repo:
https://bodhi.fedoraproject.org/updates/FEDORA-2019-8ee53ec6c0


Note You need to log in before you can comment on or make changes to this bug.