Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1715399

Summary: [machines]There is an error when deleting VM on its installation
Product: Red Hat Enterprise Linux 8 Reporter: YunmingYang <yunyang>
Component: cockpit-appstreamAssignee: Katerina Koukiou <kkoukiou>
Status: CLOSED ERRATA QA Contact: YunmingYang <yunyang>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 8.1CC: leiwang, mpitt, qiyuan, wshi, xchen
Target Milestone: rcFlags: pm-rhel: mirror+
Target Release: 8.1   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-05 20:41:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description YunmingYang 2019-05-30 09:13:09 UTC
Description of problem:
If the VM is installing, the operation of deleting will cause an error, and the VM don't be deleted, either.But the disk of this VM is deleted.


Version-Release number of selected component (if applicable):
cockpit-machines-193-1.el8.noarch
libvirt-dbus-1.2.0-2.module+el8.1.0+2983+b2ae9c0a.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Create a VM with using 'Local Install Media'
2.Click the 'install' button of the VM, then delete it
3.Using command which is 'virsh vol-list default' check the disk of the VM.

Actual results:
1. There will be an error shown on the page after step2, and the VM is not deleted.
2. The disk of the VM has been deleted

Expected results:
The VM can be deleted correctly when it is installing

Additional info:

Comment 1 Katerina Koukiou 2019-07-18 12:10:07 UTC
Fixed with:

commit 9b3927ab0b14ea975c759cc4979a9e0967c77eea
Author: Katerina Koukiou <kkoukiou>
Date:   Thu Jun 27 21:56:13 2019 +0200

    machines: don't redefine the domain when user deletes it in the middle of the installation


$ git describe 9b3927
198-49-g9b3927ab0


The VM is removed now from the UI when deleting it during installation. The error will be shown normally though, indicating that the installation failed.
I think that's expected behavior.

Comment 3 Xianghua Chen 2019-08-06 02:37:54 UTC
Verified with package:
cockpit-machines-197.1-1.el8.noarch

Steps:
1.Create a VM 
2.Click the 'install' button of the VM, then delete it.
The VM can be deleted correctly when it is installing, and an error will be shown indicating that the installation failed.

So verified.

Comment 5 errata-xmlrpc 2019-11-05 20:41:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3325