Bug 171546 - limits.conf don't pick "unlimited" settings
Summary: limits.conf don't pick "unlimited" settings
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pam   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-22 20:53 UTC by MIchael Kolmodin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: pam-0.79-9.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 10:30:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on RHS patch for pam-0.77 (5.73 KB, patch)
2005-10-23 16:20 UTC, MIchael Kolmodin
no flags Details | Diff

Description MIchael Kolmodin 2005-10-22 20:53:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I want to set the memlock ulimit parameter to "unlimited" - this is to be able to run the crossover office plugin. According to the codeweaver people the ulimit -l setting must be "unlimited" for the plugin to wrok.

If I raise the value in limts.conf, I can indeed increase the ulimit -l argument. However, if i set the hard limit for memlock in limits.conf to "unlimited" I cant increase the value of the memlock limit to more than 32, the default value. 

Version-Release number of selected component (if applicable):
pam-0.79

How reproducible:
Always

Steps to Reproduce:
1.Set memlock lhard imit in /etc/security/limits.conf ton 'unlimited'
2.log out, and in again as regular user.
3. $ ulimit -l 200
4. Watch output from ulimit, memlock is stoll 32. Should be 200.
  

Actual Results:  memlock limit is default value, 32

Expected Results:  memlock limit = 200,

Additional info:

This seems to be be recently fixed in RH server, see https://rhn.redhat.com/errata/RHBA-2005-526.html

Comment 1 MIchael Kolmodin 2005-10-23 16:20:25 UTC
Created attachment 120292 [details]
patch based on RHS patch for pam-0.77

This patch Works For Me (tm). It's one of the patches for 0.77 handling
decoding of the limits.conf as described in the Errata adopted for 0.79.


Note You need to log in before you can comment on or make changes to this bug.