Bug 171548 - Cannot use my 5.6 TB holding disk: it has negative size
Cannot use my 5.6 TB holding disk: it has negative size
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: amanda (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-22 19:39 EDT by Konstantin Olchanski
Modified: 2015-01-07 19:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 16:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Olchanski 2005-10-22 19:39:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.7.10-1.3.2

Description of problem:
Moving to a new machine with more disk space, amanda broke because it could not use the new holding disk: "amcheck" reports negative free space size.

Version-Release number of selected component (if applicable):
amanda-2.4.4p3-1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. blah...
2.
3.
  

Actual Results:  -bash-3.00$ /usr/sbin/amcheck -s daily
Amanda Tape Server Host Check
-----------------------------
WARNING: holding disk /amanda_daily_holding: only -2147483648 KB free (4284481536 KB requested)
amcheck-server: slot 5: date X        label daily0005 (new tape)
NOTE: skipping tape-writable test
Tape daily0005 label ok
Server check took 0.068 seconds

-bash-3.00$ df -k /amanda_daily_holding
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/md2             5382870976 1264819472 4016416084  24% /home1


Additional info:

amanda-2.4.5 rebuilt from sources shows the same problem.

The wrong size of the holding disk seems to be caused by an overflow(?) in common-src/statfs.c. After replacing:
-bash-3.00$ diff statfs.c statfs.c~
130c130
< #define scale(r,s)    ( (r) == -1? -1 : ((double)(r)*(double)(s)/1024.0) )
---
> #define scale(r,s)    ( (r) == -1? -1 : (int)((r)*(double)(s)/1024.0) )

The problem goes away and amanda works fine.
Comment 1 RHEL Product and Program Management 2006-09-05 15:48:34 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 2 RHEL Product and Program Management 2006-09-05 16:01:25 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.