Bug 171562 - SDL_mixer leaves music.raw behind
SDL_mixer leaves music.raw behind
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: SDL_mixer (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-23 02:59 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 22:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix music.raw trash, duplicate audio device opens, memory leak (723 bytes, patch)
2005-11-07 17:52 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-10-23 02:59:46 EDT
Playing any file through SDL_mixer appears to leave "music.raw" behind to the 
current working directory.  For example:  
  
    $ ls -l music.raw  
    ls: music.raw: No such file or directory  
    $ playmus /usr/share/sounds/alsa/Noise.wav  
    Opened audio at 22050 Hz 16 bit stereo, 4096 bytes audio buffer  
    Playing /usr/share/sounds/alsa/Noise.wav  
    $ ls -l music.raw  
    -rw-------  1 scop scop 0 Oct 23 09:56 music.raw  
 
Also happens with playwave as well as apps using SDL_mixer libs.  music.raw 
has something to do with mikmod, but this seems to happen with all sound 
files.  Other apps using mikmod (and mikmod itself) don't seem to behave that 
way, so it looks like a SDL_mixer issue.
Comment 1 Ville Skyttä 2005-11-07 17:52:35 EST
Created attachment 120798 [details]
Fix music.raw trash, duplicate audio device opens, memory leak

Okay, found the fix in upstream CVS.  This patch cures the music.raw trashing
problem, avoids mikmod/SDL_mixer possibly trying to open audio devices multiple
times, as well as fixes a memory leak.
Comment 2 Brian Pepple 2005-11-10 22:07:49 EST
Applied patch, and should be in next batch of signed rpms.  Thanks, Ville.

Note You need to log in before you can comment on or make changes to this bug.