Bug 1715633 - Setting memory thresholds under advanced config not working correctly
Summary: Setting memory thresholds under advanced config not working correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.0
Hardware: All
OS: All
high
high
Target Milestone: GA
: 5.10.11
Assignee: Brian McLaughlin
QA Contact: Jaroslav Henner
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-30 20:39 UTC by Ryan Spagnola
Modified: 2020-01-02 11:56 UTC (History)
8 users (show)

Fixed In Version: 5.10.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-09 13:51:12 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2967 None None None 2019-10-09 13:51:26 UTC

Internal Links: 1787350

Description Ryan Spagnola 2019-05-30 20:39:39 UTC
Description of problem:

* Tested with Web Service Worker

* When setting the value to 2.gigabytes under advanced config, the UI reflect 200MB.

* When setting the value to 1.5.gigabytes the value is not changed (this worked in previous versions i.e. 5.8)

Version-Release number of selected component (if applicable):
5.10.4

How reproducible:
Always

Steps to Reproduce:
1. Settings > Advanced
2. Change web_services worker to 1.5.gigabytes or 2.gigabytes
3.

Actual results:
UI shows 200MB

Expected results:
UI shows 1.5GB or 2GB

Additional info:

Comment 4 CFME Bot 2019-09-19 18:36:11 UTC
New commit detected on ManageIQ/manageiq-ui-classic/hammer:

https://github.com/ManageIQ/manageiq-ui-classic/commit/fedd06d33ec4b1573d5de46e1441265ce616106b
commit fedd06d33ec4b1573d5de46e1441265ce616106b
Author:     Brian McLaughlin <bmclaugh@redhat.com>
AuthorDate: Fri Jun 28 12:44:55 2019 -0400
Commit:     Brian McLaughlin <bmclaugh@redhat.com>
CommitDate: Fri Jun 28 12:44:55 2019 -0400

    Allow for setting custom worker memory thresholds under advanced settings

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1715633

 app/controllers/ops_controller/settings/common.rb | 19 +
 spec/controllers/ops_controller/settings/common_spec.rb | 46 +
 2 files changed, 65 insertions(+)

Comment 5 Jaroslav Henner 2019-09-30 08:23:51 UTC
The UI value now reflects what is set in the advanced_config.

Comment 7 errata-xmlrpc 2019-10-09 13:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2967


Note You need to log in before you can comment on or make changes to this bug.