Bug 1715921 - uss.t tests times out with brick-mux regression
Summary: uss.t tests times out with brick-mux regression
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-31 16:15 UTC by Raghavendra Bhat
Modified: 2019-06-08 05:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-08 05:42:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22728 None Merged uss: Ensure that snapshot is deleted before creating a new snapshot 2019-06-08 05:42:54 UTC

Description Raghavendra Bhat 2019-05-31 16:15:31 UTC
Description of problem:

uss.t testcase sometimes fails due to timeout whenever run with brick-mux enabled.

One of the results of the failure in the regression run can be found here at [1]

Found that, the reason for this is because in the test that leads to the timeout we do the following things.

Create a file (aaa in the testcase)
Take a snapshot (snap6)
Access it via uss
Delete the file (aaa)
Delete the snapshot (snap6)
Again create snapshot (snap6 i.e. same name as the one deleted above)
Again access the file 'aaa' expecting it to fail (as the file was not present
                                                  at the time of snapshot)

But we access snap6 in the last test too soon. The previous instance of snap6 might still be going through its cleanup phase causing hangs etc.

So, after deletion of the snapshot (snap6) wait to ensure that glusterd recognizes it to be not there, before proceeding with creation of the snapshot with the same name.

[1] https://build.gluster.org/job/regression-on-demand-multiplex/613/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-05-31 16:17:19 UTC
REVIEW: https://review.gluster.org/22728 (uss: Ensure that snapshot is deleted before creating a new snapshot) posted (#8) for review on master by Raghavendra Bhat

Comment 2 Worker Ant 2019-06-08 05:42:56 UTC
REVIEW: https://review.gluster.org/22728 (uss: Ensure that snapshot is deleted before creating a new snapshot) merged (#10) on master by Amar Tumballi


Note You need to log in before you can comment on or make changes to this bug.