Bug 171595 - Default Install Allows Direct Root Access
Summary: Default Install Allows Direct Root Access
Keywords:
Status: CLOSED DUPLICATE of bug 89216
Alias: None
Product: Fedora
Classification: Fedora
Component: openssh
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-24 04:36 UTC by Chris Nystrom
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-24 07:44:06 UTC


Attachments (Terms of Use)

Description Chris Nystrom 2005-10-24 04:36:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Description of problem:
The default configuration allows direct root login access. The blackhats apparently know this, because I noticed dictionary attacks on my root login from many locations around the world over a period of time. Since there is nothing special about my systems, I assume this is a widespread problem.

I believe better practice would be to have the direct root login disabled. A firewall can mitigate this issue, but I believe it is poor practice to rely only on the firewall for protection. The system should be delivered secure.

I believe that implementing this fix will not cause any undo restriction as legitimate users can easily login via unprivledged accounts and su to root.

Also I note that Solaris is delivered with direct ssh login to root disabled. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC4
2. Login via OpenSSH direct to root.
3. Unfortunately it works.
  

Actual Results:  You have root access to the machine.

Expected Results:  Login should be denied, forcing you to login via a non-privledged account and su to root. Users who need direct login to root can easily re-enable this feature.

Additional info:

Comment 1 Tomas Mraz 2005-10-24 07:44:06 UTC

*** This bug has been marked as a duplicate of 89216 ***


Note You need to log in before you can comment on or make changes to this bug.