This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 171604 - mDNSResponder runs as "nobody"
mDNSResponder runs as "nobody"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: howl (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-24 05:29 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 17:35:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-10-24 05:29:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
The mDNSResponder process runs as "nobody". This seems like a bug.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Jason Vas Dias 2005-12-20 17:35:03 EST
No, this is not a bug - the mDNSResponder is intentionally run as 'nobody'
in the initscript, to ensure it has non-root privileges.
There are no problems caused by it running as 'nobody' .
Comment 2 Need Real Name 2005-12-20 18:23:49 EST
This bug was more "why doesn't it have it's own username" than "is it meant to
run as nobody", sorry if I wasn't more clear.

For example, postfix, bind, httpd, etc etc all run with their own uid.

Say somebody writes a simple daemon, and sees the nobody account. "I'll use
that", they think. Now the daemon and the nobody account have permissions on
each others data.

Why doesn't mDNSResponder follow the behaviour of the other packages?

Note You need to log in before you can comment on or make changes to this bug.