Bug 1716040 - [RFE] Create an ansible role for setting clevis client with a tang server.
Summary: [RFE] Create an ansible role for setting clevis client with a tang server.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: clevis
Version: 8.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 8.2
Assignee: Sergio Correia
QA Contact: Martin Zelený
Mirek Jahoda
URL:
Whiteboard:
Depends On:
Blocks: 1822182
TreeView+ depends on / blocked
 
Reported: 2019-06-01 08:45 UTC by Thorsten Scherf
Modified: 2021-05-26 06:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
.New Ansible role provides automated deployments of Clevis clients This update of the `rhel-system-roles` package introduces the `nbde_client` RHEL system role. This Ansible role enables you to deploy multiple Clevis clients in an automated way.
Clone Of:
Environment:
Last Closed: 2021-05-26 05:58:38 UTC
Type: Feature Request
Target Upstream Version:


Attachments (Terms of Use)

Description Thorsten Scherf 2019-06-01 08:45:48 UTC
Description of problem:


Please provide an Ansible role for setting up a clevis client against a tang server.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Martin Zelený 2019-11-13 14:54:38 UTC
Special testing will be needed.

Comment 4 Sergio Correia 2020-06-05 13:58:21 UTC
PR: https://github.com/linux-system-roles/nbde_client/pull/3

Comment 9 CongLi 2021-05-26 05:58:38 UTC
Since the issue described in this bug should be resolved (VERIFIED), it has been closed with a resolution of CURRENTRELEASE.

If the fix for this is not released yet, check if this will ever get fixed. In case of a negative answer (ex: for  zstream releases that won't be updated anymore) then please change it as WONTFIX.

If there's anything else to be done on this BZ, if it's still active, please reopen this bug with comment.

Please note: for those bugs which are not included in errata, please add keyword 'TestOnly'.
TestOnly: Use this when there is no code delivery involved, or for use when code is already upstream and will be incorporated automatically to the next release for testing purposes only.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.