Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1716258

Summary: Failed to start guest with erro there is no hub at port 1 in USB address bus: 0 port: 1.1
Product: [oVirt] ovirt-engine Reporter: yafu <yafu>
Component: BLL.VirtAssignee: Steven Rosenberg <srosenbe>
Status: CLOSED DUPLICATE QA Contact: meital avital <mavital>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.3.3.7CC: bugs, jiyan, michal.skrivanek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-07-23 07:44:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description yafu 2019-06-03 03:23:16 UTC
Description of problem:
Failed to start guest with erro there is no hub at port 1 in USB address bus: 0 port: 1.1 .

Version-Release number of selected component (if applicable):
RHV server:
rhvm-4.3.3.7-0.1.el7.noarch

RHV host:
vdsm-4.30.15-1.el7ev.x86_64
qemu-kvm-rhev-2.12.0-28.el7.x86_64
libvirt-4.5.0-17.el7.x86_64
kernel-3.10.0-1048.el7.x86_64

How reproducible:
100% in my env


Steps to Reproduce:
1.Create a guest using template and star it, the guest failed to start;

2.Check the log, there is a 1.0 usb controller but not have hub for the controller:
<?xml version="1.0" encoding="UTF-8"?>
<domain type="kvm" xmlns:ovirt-tune="http://ovirt.org/vm/tune/1.0" xmlns:ovirt-vm="http://ovirt.org/vm/1.0">
  <name>yafu-77-2</name>
...
 <controller type="usb" model="piix3-uhci" index="0">
      <address bus="0x00" domain="0x0000" function="0x2" slot="0x01" type="pci"/>
    </controller>
...
</domain>


[org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ForkJoinPool-1-worker-1) [4b9d0c8b] EVENT_ID: VM_DOWN_ERROR(119), VM yafu-77-2 is down with error. Exit message: XML error: there is no hub at port 1 in USB address bus: 0 port: 1.1.

Actual results:
Failed to start guest with error there is no hub at port 1 in USB address bus: 0 port: 1.1 .


Expected results:
When there is 1.0 usb controller, should add the hub for the controller automatically, then the guest can start successfully.

Additional info:

Comment 4 Michal Skrivanek 2019-06-04 12:43:55 UTC
partially covered by bug 1715393

Comment 8 Steven Rosenberg 2019-07-23 07:44:03 UTC

*** This bug has been marked as a duplicate of bug 1715393 ***