Bug 1716294 - Could not create host via hammer : Unable to delete PuppetCA certificate
Summary: Could not create host via hammer : Unable to delete PuppetCA certificate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.6.0
Assignee: Ewoud Kohl van Wijngaarden
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-03 07:26 UTC by Nikhil Kathole
Modified: 2019-10-22 13:32 UTC (History)
7 users (show)

Fixed In Version: foreman-proxy-1.22.0-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-22 13:30:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 26823 Normal Closed PuppetCA command line implementation fails with uninitialized constant Proxy::PuppetCa::PuppetcaPuppetCert::PuppetcaImpl... 2020-05-01 21:41:16 UTC
Red Hat Product Errata RHBA-2019:3175 None None None 2019-10-22 13:32:42 UTC

Description Nikhil Kathole 2019-06-03 07:26:25 UTC
Description of problem:

Could not create host via hammer.

[ERROR 2019-06-03T03:19:15 API] 422 Unprocessable Entity
[DEBUG 2019-06-03T03:19:15 API] {
    "errors" => {
                   "conflict" => [],
        "interfaces.conflict" => [],
                       "base" => [
            [0] "Cleanup PuppetCA certificates for test.example.com task failed with the following error: ERF12-7740 [ProxyAPI::ProxyException]: Unable to delete PuppetCA certificate for test.example.com ([RestClient::NotAcceptable]: 406 Not Acceptable) for Capsule https://qe-sat6-feature-example.com:9090/puppet/ca"
        ]
    }
}
[DEBUG 2019-06-03T03:19:15 Exception] Using exception handler HammerCLIForeman::ExceptionHandler#handle_unprocessable_entity
[ERROR 2019-06-03T03:19:15 Exception] <NilClass> nil
Could not create the host


Version-Release number of selected component (if applicable):
Satellite 6.6 snap 4


How reproducible: always


Steps to Reproduce:
1. # hammer hostgroup info --organization-id=1 --location-id=2 --name="RHEL 7 Server 64-bit HG"Id:                    2
Name:                  RHEL 7 Server 64-bit HG
Title:                 RHEL 7 Server 64-bit HG
Puppet Environment:    production
Puppet CA Proxy:       qe-sat6-feature-example.com
Puppet Master Proxy:   qe-sat6-feature-example.com
Network:               
    Subnet ipv4: katello_latest
    Domain:      example.com
Operating system:      
    Architecture:     x86_64
    Operating System: RedHat 7.6
    Partition Table:  Kickstart default
    PXE Loader:       PXELinux BIOS
Puppetclasses:         
    access_insights_client
    foreman_scap_client
Parameters:            
    kt_activation_keys => ak-rhel-7
Locations:             
    Default Location
Organizations:         
    Default Organization
OpenSCAP Proxy:        
Content View:          
    ID:   2
    Name: RHEL 7 CV
Lifecycle Environment: 
    ID:   2
    Name: DEV
Content Source:        
    ID:   1
    Name: qe-sat6-feature-example.com
Kickstart Repository:  
    ID:   19
    Name: 19


2. hammer --debug host create --name=test --root-password='changeme' --organization-id=1 --location-id=2 --hostgroup="RHEL 7 Server 64-bit HG" --compute-resource='libvirt' --compute-attributes="cpus=1, memory=1073741824, start=1" --interface="primary=true, compute_type=bridge, compute_bridge=katello_latest, compute_model=virtio" --volume="capacity=10G,format_type=qcow2"

Actual results:

Hammer throws error as "Could not create the host" but when you see in UI, it is successfully created.


Expected results:

Hammer should not throw error.


Additional info: Regression.

Comment 8 Jitendra Yejare 2019-06-14 06:56:12 UTC
The issue is observed while provisioning:
        - from UI also
        - on VMWare and GCE

Comment 9 Marek Hulan 2019-06-24 12:30:01 UTC
Linking a known upstream issue, should be fixed by now (since snap 6)

Comment 10 Nikhil Kathole 2019-06-24 12:40:56 UTC
FailedQA

Version tested:
Satellite 6.6 snap 7

# rpm -qa | grep satellite
satellite-maintain-0.0.1-1.el7sat.noarch
satellite-installer-6.6.0.11-1.beta.el7sat.noarch
satellite-cli-6.6.0-5.beta.el7sat.noarch
satellite-common-6.6.0-5.beta.el7sat.noarch
satellite-6.6.0-5.beta.el7sat.noarch
tfm-rubygem-foreman_theme_satellite-4.0.1.1-1.el7sat.noarch

PR linked is not part of satellite snap. I guess we are missing cherry-pick.

Comment 11 Bryan Kearney 2019-06-24 14:05:12 UTC
Upstream bug assigned to ekohlvan@redhat.com

Comment 13 Ewoud Kohl van Wijngaarden 2019-06-26 11:29:02 UTC
Not sure why the automation didn't pick this up and moved it to POST, but upstream it's been fixed in 1.22.0-RC2.

Comment 14 Nikhil Kathole 2019-07-03 10:58:43 UTC
VERIFIED

version tested:
Satellite 6.6.0 snap 9

Successfully created host with hammer.

Comment 17 errata-xmlrpc 2019-10-22 13:30:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3175


Note You need to log in before you can comment on or make changes to this bug.