Bug 1716341 - [OSP15] Missing bridge mappings for controller nodes for non_dvr CI jobs
Summary: [OSP15] Missing bridge mappings for controller nodes for non_dvr CI jobs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 15.0 (Stein)
Assignee: Maciej Józefczyk
QA Contact: Eran Kuris
URL:
Whiteboard:
: 1726196 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-03 09:21 UTC by Eran Kuris
Modified: 2019-09-26 10:51 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:22:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gerrithub.io 456624 0 None None None 2019-06-13 14:02:33 UTC
Gerrithub.io 465759 0 None None None 2019-08-20 09:06:54 UTC
OpenStack gerrit 663255 0 'None' 'NEW' 'Explicitly disable DVR for OVN HA deployment' 2019-11-17 12:10:40 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:22:55 UTC

Description Eran Kuris 2019-06-03 09:21:33 UTC
Description of problem:
External traffic does not work on OSP15 non-Dvr deployment. 
It looks like the Compute node become to be gw chassis when they should not be.
()[root@controller-0 /]# ovn-nbctl lrp-get-gateway-chassis lrp-5da502dc-6c4f-48e6-8a89-c7fe0fd2fe7b                                                                          
lrp-5da502dc-6c4f-48e6-8a89-c7fe0fd2fe7b_d2bcdfbd-4db5-4654-a959-d755f98de1cf     5
lrp-5da502dc-6c4f-48e6-8a89-c7fe0fd2fe7b_51cea727-59aa-4778-a364-5e89ae65282f     4
lrp-5da502dc-6c4f-48e6-8a89-c7fe0fd2fe7b_abc91495-7871-43eb-868f-6bd0a695d16f     3
lrp-5da502dc-6c4f-48e6-8a89-c7fe0fd2fe7b_f8dadace-d7b9-4dad-bd40-0102338f8dbf     2
lrp-5da502dc-6c4f-48e6-8a89-c7fe0fd2fe7b_6a0c48c5-0c67-4c74-9576-f596a8ebb46e     1

960-7e86-454d-bc55-1b1d0dd8a6e5", "neutron:ovn-metadata-id"="fa0cdc78-39de-4eac-998b-e33fb137819e", "neutron:ovn-metadata-sb-cfg"="6310", ovn-bridge-mappings="", ovn-cms-options=""}
hostname            : "compute-0.localdomain"
name                : "d2bcdfbd-4db5-4654-a959-d755f98de1cf"
nb_cfg              : 6310
transport_zones     : []
vtep_logical_switches: []

Version-Release number of selected component (if applicable):
OpenStack/15.0-RHEL-8/RHOS_TRUNK-15.0-RHEL-8-20190528.n.2

rhosp-openvswitch-ovn-central-2.11-0.3.el8ost.noarch
puppet-ovn-14.4.1-0.20190420043650.20090c6.el8ost.noarch
rhosp-openvswitch-ovn-common-2.11-0.3.el8ost.noarch
ovn2.11-central-2.11.0-16.el8fdp.x86_64
ovn2.11-2.11.0-16.el8fdp.x86_64

How reproducible:
100%

Steps to Reproduce:
1. run CI non-dvr deployment  all scenario tests that use FIP are failing 
2. manual test: create virtual env with FIP and try to ping the FIP of the vms  
3.

Actual results:


Expected results:


Additional info:
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/DFG/view/network/view/networking-ovn/job/DFG-network-networking-ovn-15_director-rhel-virthost-3cont_2comp-ipv4-geneve-non_dvr/18/testReport/

Comment 9 Roman Safronov 2019-07-02 11:19:05 UTC
*** Bug 1726196 has been marked as a duplicate of this bug. ***

Comment 25 errata-xmlrpc 2019-09-21 11:22:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.