Bug 1716370 - python2-celery fails to install due to several missing dependencies
Summary: python2-celery fails to install due to several missing dependencies
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: python-celery
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Randy Barlow
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PY2FTBI F31FailsToInstall 1716369
TreeView+ depends on / blocked
 
Reported: 2019-06-03 10:43 UTC by Miro Hrončok
Modified: 2019-06-06 16:21 UTC (History)
5 users (show)

Fixed In Version: python-celery-4.2.1-5.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-06 16:16:09 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-06-03 10:43:49 UTC
$ mock -r fedora-rawhide-x86_64 install python2-celery
Error: 
 Problem: conflicting requests
  - nothing provides python2-billiard >= 1:3.5.0.2 needed by python2-celery-4.2.1-4.fc30.noarch
  - nothing provides python2-kombu >= 1:4.2.0 needed by python2-celery-4.2.1-4.fc30.noarch
  - nothing provides python2.7dist(billiard) >= 3.5.0.2 needed by python2-celery-4.2.1-4.fc30.noarch
  - nothing provides python2.7dist(billiard) < 3.6.0 needed by python2-celery-4.2.1-4.fc30.noarch
  - nothing provides python2.7dist(kombu) >= 4.2.0 needed by python2-celery-4.2.1-4.fc30.noarch
  - nothing provides python2.7dist(kombu) < 5.0 needed by python2-celery-4.2.1-4.fc30.noarch

Comment 1 Randy Barlow 2019-06-06 15:55:52 UTC
Miro.

Are you ready for some good news?

Comment 2 Miro Hrončok 2019-06-06 16:02:46 UTC
You are going to support Python 2 instead of me?

Comment 3 Randy Barlow 2019-06-06 16:07:49 UTC
Nope!

$ dnf repoquery --whatrequires python2-celery --recursive
$

Comment 4 Randy Barlow 2019-06-06 16:16:09 UTC
Miro, I've fixed the fail to install on python2-celery by removing python2-celery, which is hilarious because it means that I fixed the failure to install python2-celery by making it so that python2-celery fails to install because it doesn't exist. FTI == FTI. QED?

Comment 5 Miro Hrončok 2019-06-06 16:21:49 UTC
Oh. You made the problem permanent. Thanks.


Note You need to log in before you can comment on or make changes to this bug.