Bug 1716384 - automake 1.16.1 bug on am__pep3147_tweak
Summary: automake 1.16.1 bug on am__pep3147_tweak
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: automake
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Patrik Novotný
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: oVirt_on_Fedora
TreeView+ depends on / blocked
 
Reported: 2019-06-03 11:45 UTC by Sandro Bonazzola
Modified: 2019-10-02 01:40 UTC (History)
5 users (show)

Fixed In Version: automake-1.16.1-7.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-02 01:40:31 UTC


Attachments (Terms of Use)

Description Sandro Bonazzola 2019-06-03 11:45:05 UTC
Description of problem:
In projects using automake for handling python packages "make uninstall" fails due to a bug in am__pep3147_tweak
More info on the issue can be found in http://gnu-automake.7480.n7.nabble.com/bug-31222-automake-1-16-1-am-pep3147-tweak-bug-td22937.html#a23017

Fixing patch has been already merged upstream: http://git.savannah.gnu.org/cgit/automake.git/commit/?id=a348d830659fffd2cfc42994524783b07e69b4b5


Version-Release number of selected component (if applicable):
automake-1.16.1-5.fc29.noarch


How reproducible: 100%


Steps to Reproduce:
reproduced while working on ovirt-hosted-engine-setup:


1. git clone git://gerrit.ovirt.org/ovirt-hosted-engine-setup
2. autoreconf -ivf
3. ./configure
4. make uninstall  (or make distcheck, which calls make uninstall)

Actual results:
[2019-05-31T11:38:43.568Z] make[4]: Entering directory '/home/jenkins/workspace/ovirt-hosted-engine-setup_standard-check-patch/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-2.4.0-0.0.master/_build/sub/src/ovirt_hosted_engine_setup'

[2019-05-31T11:38:43.568Z] /bin/sh: -c: line 11: syntax error near unexpected token `|'

[2019-05-31T11:38:43.568Z] /bin/sh: -c: line 11: `echo "$py_files" |  | sed '$!N;$!N;$!N;$!N;$!N;$!N;$!N;s/\n/ /g' | sed '$!N;$!N;$!N;$!N;s/\n/ /g' | \'

[2019-05-31T11:38:43.568Z] make[4]: *** [Makefile:477: uninstall-dist_ovirthostedenginelibPYTHON] Error 1

[2019-05-31T11:38:43.568Z] make[4]: Leaving directory '/home/jenkins/workspace/ovirt-hosted-engine-setup_standard-check-patch/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-2.4.0-0.0.master/_build/sub/src/ovirt_hosted_engine_setup'



Expected results:
automake doesn't fail

Comment 1 Fedora Update System 2019-06-04 13:53:46 UTC
FEDORA-2019-4ee120a759 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ee120a759

Comment 2 Fedora Update System 2019-06-05 03:05:37 UTC
automake-1.16.1-6.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ee120a759

Comment 3 Pavel Raiskup 2019-06-06 07:47:48 UTC
Note there's -1 in this update:
https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ee120a759

Comment 4 Fedora Update System 2019-06-18 14:31:13 UTC
FEDORA-2019-4ee120a759 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ee120a759

Comment 5 Fedora Update System 2019-06-19 04:13:48 UTC
automake-1.16.1-7.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ee120a759

Comment 6 Sandro Bonazzola 2019-10-01 12:23:40 UTC
Seems to be solved on fc29 but still there in fc30:

automake - noarch 1.16.1-12.fc30

make[4]: Entering directory '/home/jenkins/workspace/ovirt-hosted-engine-ha_standard-check-patch/ovirt-hosted-engine-ha/ovirt-hosted-engine-ha-2.4.0-0.0.master.20191001121531/_build/sub/ovirt_hosted_engine_ha/lib/ovf'
/bin/sh: -c: line 11: syntax error near unexpected token `|'
/bin/sh: -c: line 11: `echo "$py_files" |  | sed '$!N;$!N;$!N;$!N;$!N;$!N;$!N;s/\n/ /g' | sed '$!N;$!N;$!N;$!N;s/\n/ /g' | \'
make[4]: *** [Makefile:381: uninstall-dist_ovflibPYTHON] Error 1

Comment 7 Fedora Update System 2019-10-02 01:40:31 UTC
automake-1.16.1-7.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.