Bug 1716422 - perl-Test-Unit-0.25-32.fc31 FTBFS with perl 5.30: test_numericness test fails on 0xF00
Summary: perl-Test-Unit-0.25-32.fc31 FTBFS with perl 5.30: test_numericness test fails...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Test-Unit
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-03 13:13 UTC by Petr Pisar
Modified: 2019-06-03 14:40 UTC (History)
2 users (show)

Fixed In Version: perl-Test-Unit-0.25-33.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-03 14:40:35 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 129738 0 None None None 2019-06-03 14:35:18 UTC

Internal Links: 1749253

Description Petr Pisar 2019-06-03 13:13:17 UTC
perl-Test-Unit-0.25-32.fc31 fails build with perl 5.30 because a test started to fail:

$ perl -Ilib t/assert.t                                    
STARTING TEST RUN                                                                         
1..40                                                                                     
[...]
ok PASS test_assert_raises

not ok ERROR test_numericness
t/tlib/AssertTest.pm:48 - test_numericness(Class::Inner::__A26)
For string '0xF00', expect f but got t
ok PASS test_fail_assert_null

That's caused by a change in perl. Perl 5.28 handles it as string:

$ perl -e 'print qq{YES\n} if q{0xF00} == 0'
YES

While perl 5.30 handles it as a number:

$ perl -e 'print qq{YES\n} if q{0xF00} == 0'

The failing test has a relevant notice at t/tlib/AssertTest.pm:37:

    '0xF00' => 'f', # controversial?  but if you +=10 then it's == 10


Note You need to log in before you can comment on or make changes to this bug.