Bug 1716468 - libcec fails to build with Python 3.8
Summary: libcec fails to build with Python 3.8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libcec
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL: https://copr.fedorainfracloud.org/cop...
Whiteboard:
Depends On:
Blocks: PYTHON38 F32FTBFS F32FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-06-03 14:35 UTC by Miro Hrončok
Modified: 2019-10-16 17:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 17:01:35 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-06-03 14:35:50 UTC
See https://copr.fedorainfracloud.org/coprs/g/python/python3.8/package/libcec/ for actual logs. This report is automated and not very verbose, but feel free to ping me for help.

Comment 1 Miro Hrončok 2019-07-10 12:29:45 UTC
rpm says:

error: Directory not found: /builddir/build/BUILDROOT/libcec-4.0.4-3.fc31.x86_64/usr/lib64/python3.8/site-packages/cec

This is bacause:

-- Installing: /builddir/build/BUILDROOT/libcec-4.0.4-3.fc31.x86_64/usr/lib64/python3.8.0b2/site-packages/cec/_cec.so

That should instead do:

-- Installing: /builddir/build/BUILDROOT/libcec-4.0.4-3.fc31.x86_64/usr/lib64/python3.8/site-packages/cec/_cec.so

Not sure what get's into $PYTHON_VERSION in https://src.fedoraproject.org/rpms/libcec/blob/master/f/libcec-pythonlib.patch but it seems it is the full version instead of X.Y.

Comment 2 Miro Hrončok 2019-07-10 12:32:21 UTC
This line is probably the cause:

libcec-libcec-4.0.4/src/libcec/cmake/CheckPlatformSupport.cmake
180:      string(REGEX REPLACE "\\.[0-9]+\\+?$" "" PYTHON_VERSION ${PYTHONLIBS_VERSION_STRING})



See:

$ echo 3.8.0 | sed -E 's@\.[0-9]+\+?$@@'
3.8

But:

$ echo 3.8.0b2 | sed -E 's@\.[0-9]+\+?$@@'
3.8.0b2

Comment 3 Charalampos Stratakis 2019-07-23 14:48:17 UTC
Please respond.

Comment 4 Peter Robinson 2019-07-23 15:03:34 UTC
(In reply to Charalampos Stratakis from comment #3)
> Please respond.

To what exactly? Python 3.8 isn't in F-31 and hence even rawhide yet.

Comment 5 Miro Hrončok 2019-07-23 15:12:49 UTC
It is not. In case you need some place to fix this, check out http://copr.fedorainfracloud.org/coprs/g/python/python3.8/ - in case you don't consider that important at the moment, just say so and we'll stop bothering you.

Comment 6 Peter Robinson 2019-07-24 08:04:17 UTC
(In reply to Miro Hrončok from comment #5)
> It is not. In case you need some place to fix this, check out
> http://copr.fedorainfracloud.org/coprs/g/python/python3.8/ - in case you
> don't consider that important at the moment, just say so and we'll stop
> bothering you.

I don't, I'll deal with when I can test it in Fedora directly and have time.

Comment 7 Ben Cotton 2019-08-13 18:56:59 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 8 Miro Hrončok 2019-08-14 22:24:47 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 9 Miro Hrončok 2019-08-21 16:35:34 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32


If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-6.3.0.4-3.fc32

Thanks!

(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 10 Miro Hrončok 2019-08-21 17:29:32 UTC
(Python 3.8 has landed in the rawhide buildroot.)


Note You need to log in before you can comment on or make changes to this bug.