Bug 1716486 - python-aiosmtpd fails to build with Python 3.8
Summary: python-aiosmtpd fails to build with Python 3.8
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-aiosmtpd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL: https://copr.fedorainfracloud.org/cop...
Whiteboard:
Depends On:
Blocks: F32FTBFS F32FailsToInstall PYTHON38
TreeView+ depends on / blocked
 
Reported: 2019-06-03 14:37 UTC by Miro Hrončok
Modified: 2019-09-30 10:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-30 10:05:20 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2019-06-03 14:37:26 UTC
See https://copr.fedorainfracloud.org/coprs/g/python/python3.8/package/python-aiosmtpd/ for actual logs. This report is automated and not very verbose, but feel free to ping me for help.

Comment 1 Karthikeyan Singaravelan 2019-06-23 17:33:21 UTC
I can reproduce the errors on master branch of aiosmtpd with Python 3.8. It seems be due to https://bugs.python.org/issue26467 where AsyncMock is now returned while patching coroutines instead of MagicMock in 3.7 . There also seems to be a bug that in AsyncMock the synchronous API like call_args, call_count etc are not recorded for which I will try to open an issue in CPython tracker. This seems to be an issue with tests only and not with the library. The old behavior of Python 3.7 can be retained to use MagicMock for coroutines too to fix this which is an one line change in aiosmtpd tests if this is a blocker.

aiosmtpd issue : https://github.com/aio-libs/aiosmtpd/issues/167

Thanks for your efforts on Python 3.8 testing

Comment 2 Karthikeyan Singaravelan 2019-06-28 18:50:21 UTC
I have raised an upstream PR to fix the tests that would unblock the rebuild : https://github.com/aio-libs/aiosmtpd/pull/169/files

Comment 3 Ben Cotton 2019-08-13 16:49:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 4 Miro Hrončok 2019-08-14 22:24:53 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 5 Miro Hrončok 2019-08-21 16:35:39 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32


If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-6.3.0.4-3.fc32

Thanks!

(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 6 Miro Hrončok 2019-08-21 17:29:37 UTC
(Python 3.8 has landed in the rawhide buildroot.)

Comment 7 Miro Hrončok 2019-09-16 08:33:07 UTC
This issue is blocking the Python 3.8 rebuilds. If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32.
Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Could you please backport the fix?

Comment 8 Aurelien Bompard 2019-09-30 10:03:49 UTC
I've backported the fix and the package is now built in Rawhide and F31. Sorry for the long wait and thanks for your patience.


Note You need to log in before you can comment on or make changes to this bug.