Bug 17165 - 32 bit UID Support
32 bit UID Support
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-01 02:02 EDT by TJ McNeely
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-01 02:02:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description TJ McNeely 2000-09-01 02:02:27 EDT
I hear that the new kernel supports 32 bit UID's.. I notice pieces/parts of
the 2.4.0 kernel in the /usr/src/ folder, but it is not all there.. i am
going to try installing the test7 kernel to see if that fixes this, but I
doubt it.

My organization runs unix (Solaris 7/8) on all desktops and has NFS home
directories.. I would like to run Linux on my desktop, however it has YET
to support the super HIGH UID's. I attempted the 2.4.0 kernel on 6.2 and
kept getting suid errors when attempting to log in.. which means I was
actually binding to the NIS server an authenticating, but none of the
internal stuff could handle it.

My UID is 103292 and they are in the 120000's now  I think.. I need to be
able to log in with my UID cause they (ofcourse) dont have no_root_squash
turned on.

So this isn't really a YPBIND issue (as I am able to ypbind) and maybe if I
could get some VP's or CEO's to log in they would be fine, but since our
UIDs are 1000 higer than our Employee ID, we are sorta limited here.

Any advice would be appreciated.

Thanks,
TJ McNeely
(A certain un-named unix company)
KnopHead@Yahoo.com
Comment 1 Preston Brown 2000-10-16 15:22:02 EDT
We are sorry, but we are not officially supporting the 2.4 kernel yet, and thus
not large UIDs/GIDs.

Note You need to log in before you can comment on or make changes to this bug.