Bug 171651 - dmraid activates single disk configuration
dmraid activates single disk configuration
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dmraid (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-24 15:39 EDT by David Milburn
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-12 11:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Milburn 2005-10-24 15:39:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
If meta-data tag exists on disk, dmraid will activate it even if it is a single disk configuration and not a raid array.

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc8-1_RHEL4_U2-i386

How reproducible:
Always

Steps to Reproduce:
1. Boot system 
2. Mount device
3. 
  

Actual Results:  Cannot mount device, EBUSY.

mount("/dev/sdd3", "/export/d3", "ext3", MS_RDONLY, 0) = -1 EBUSY (Device or resource busy) 

Expected Results:  Should be able to mount device since dmraid shouldn't activated single disk configuration.

Additional info:

Workaround is to erase meta-data

dmraid -r -E /dev/sdd
Comment 7 RHEL Product and Program Management 2006-08-18 13:09:49 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.