Bug 1716554 - [OSP15] RBACSharedNetworksTest.test_duplicate_policy_error fails because Neutron keeps retrying
Summary: [OSP15] RBACSharedNetworksTest.test_duplicate_policy_error fails because Neut...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Jakub Libosvar
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-03 15:23 UTC by Jakub Libosvar
Modified: 2019-09-26 10:51 UTC (History)
4 users (show)

Fixed In Version: openstack-neutron-14.0.2-0.20190614231136.3733721.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:22:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1831647 0 None None None 2019-06-04 16:52:33 UTC
OpenStack gerrit 663749 0 None master: MERGED neutron: rbac: Catch correct exception for duplicated entry (I7c65376f6fd6fc29d510ea532a684917ed95deb1) 2019-06-17 12:48:39 UTC
OpenStack gerrit 664519 0 None stable/stein: MERGED neutron: rbac: Catch correct exception for duplicated entry (I7c65376f6fd6fc29d510ea532a684917ed95deb1) 2019-06-17 12:48:45 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:10 UTC

Description Jakub Libosvar 2019-06-03 15:23:01 UTC
Description of problem:
neutron_tempest_plugin.api.admin.test_shared_network_extension.RBACSharedNetworksTest.test_duplicate_policy_error tests that an attempt to create an existing network rbac policy fails with proper error. Client expects a conflicting response from the server, however client bails out after it hits HTTP timeout with 504 code and following message "<html><body><h1>504 Gateway Time-out</h1>\nThe server didn't respond in time.\n</body></html>\n"

The reason is that the retry mechanism in Neutron is triggered when there is an existing entry in the database, hence Neutron keeps trying to create the entry 20 times.

$ grep "Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy" server.log
2019-06-01 12:07:45.818 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:07:46.971 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:07:48.083 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:07:50.186 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:07:51.707 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:07:59.067 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:08:09.052 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:08:19.588 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:08:30.290 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:08:41.252 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:08:51.845 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:09:02.596 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:09:13.276 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:09:20.370 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:09:31.186 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156
2019-06-01 12:09:41.736 [c0] 24 DEBUG oslo_db.api [req-3e52bd47-d430-4728-964a-756e8c92feb4 485fadc82b5a4657bbec68b54c08c6f7 c0fa77e90d134c629d2c01c955e5fc22 - default default] Performing DB retry for function neutron.db.rbac_db_mixin.RbacPluginMixin.create_rbac_policy wrapper /usr/lib/python3.6/site-packages/oslo_db/api.py:156

then the client disconnects:
ConnectionResetError: [Errno 104] Connection reset by peer


Version-Release number of selected component (if applicable):




Steps to Reproduce:
1. Create a network with shared rbac policy
2. Create the same shared rbac policy
3.

Actual results:
504

Expected results:
409

Additional info:

Comment 11 errata-xmlrpc 2019-09-21 11:22:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.