Bug 1716569 - fedpkg update: Could not execute update
Summary: fedpkg update: Could not execute update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bodhi
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Randy Barlow
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-03 16:26 UTC by Jaroslav Škarvada
Modified: 2019-06-12 02:05 UTC (History)
9 users (show)

Fixed In Version: bodhi-4.0.2-1.fc30 bodhi-4.0.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-12 00:45:54 UTC


Attachments (Terms of Use)

Description Jaroslav Škarvada 2019-06-03 16:26:17 UTC
Description of problem:
The 'fedpkg update' starts throwing cryptic error message.

Version-Release number of selected component (if applicable):
fedpkg-1.37-1.fc29.noarch

How reproducible:
Always

Steps to Reproduce:
1. fedpkg update
2.
3.

Actual results:
Could not execute update: Could not generate update request: 'anonymous'
A copy of the filled in template is saved as bodhi.template.last

Expected results:
No error

Additional info:
Maybe it's not fedpkg, but bodhi?

Comment 1 Jaroslav Škarvada 2019-06-03 16:27:10 UTC
But despite the error it seems the update was generated in bodhi without problem.

Comment 2 Ondřej Nosek 2019-06-04 11:05:52 UTC
Hi Jaroslav,

This error should be caused by bodhi-client. Recently bodhi v.4 was deployed on the server and it needs a proper client. I do not know whether is available or not. But fedpkg is not guilty as far as I know.

Comment 3 Jaroslav Škarvada 2019-06-04 14:12:40 UTC
(In reply to Ondřej Nosek from comment #2)
> Hi Jaroslav,
> 
> This error should be caused by bodhi-client. Recently bodhi v.4 was deployed
> on the server and it needs a proper client. I do not know whether is
> available or not. But fedpkg is not guilty as far as I know.

Thanks, for info, I suspect it's bodhi :), reassigning to bodhi.

Comment 4 Fedora Update System 2019-06-04 15:36:09 UTC
FEDORA-2019-352078fd2b has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-352078fd2b

Comment 5 Fedora Update System 2019-06-04 15:36:15 UTC
FEDORA-2019-5ce9adadc1 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5ce9adadc1

Comment 6 Fedora Update System 2019-06-12 00:45:54 UTC
bodhi-4.0.2-1.fc30, bodhi3-3.14.0-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2019-06-12 02:05:13 UTC
bodhi-4.0.2-1.fc29, bodhi3-3.12.0-200.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.