Bug 17167 - Kernel recompile fails on Duron system
Summary: Kernel recompile fails on Duron system
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-01 07:57 UTC by Kevin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-01 07:57:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin 2000-09-01 07:57:47 UTC
System hangs at different location on each attempt when doing a make bzImage. Happens with both 2.2.14 and 2.2.16 kernels.

System is a Duron 600 with MSI 6340 MB. I have replaced all the hardware except the processor and still get the same result. The memory is a 
quality item and I have tried both 64MB PC133 and 128MB PC100. I have also tried different memory timings in BIOS. The system has run 
successfully for > 48 hours using a windows CPU burn program so it doesn't look like a hardware problem.

I am able to compile other stuff such as Apache and MySQL.

Comment 1 Michael K. Johnson 2000-09-01 08:33:43 UTC
Kernel compiles fine on our Duron 700, including lots of stress
testing like multiple parallel kernel compilations...

Comment 2 Kevin 2000-09-01 09:27:29 UTC
Did you make any changes to the make file from the default specifically for your Duron or did it work 'out of the crate'?

Comment 3 Michael K. Johnson 2000-09-01 20:31:44 UTC
"Out of the crate".  No patches.

Our 2.2.14 kernel that came with 6.2 is known not to work at all
on Duron and Thunderbird; the workaround is to explicitly install
the 386 kernel, boot that, and use it to upgrade to the 2.2.16-3
errata kernel, which does work correctly on Duron on Thunderbird.
But that doesn't have anything to do with your problem, because
the non-functioning kernels halt early in the boot sequence.


Note You need to log in before you can comment on or make changes to this bug.