Bug 171691 - Package Mangement program needs improvements for ease of use
Summary: Package Mangement program needs improvements for ease of use
Status: CLOSED DUPLICATE of bug 171688
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-packages   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-25 11:04 UTC by Matthew
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 16:10:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew 2005-10-25 11:04:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
With the current version of Fedora Core 4, the graphical packagement management utility does not have ability to search through the many different package names listed in both the 'Standard Packages' and 'Extra Packages'. Can it be simply be redesigned the whole program so you can have the ability filter and/or sort the packages based on different criteria:-
    - What's Installed and What's Not.
    - Sort Filesizes from smallest to largest and vice versa.
    - Based on specific categories such as 'Web Server' or 'Games and  Entertainment'.
    - sort packages filenames alphabetically either from A to Z or from Z to A.

Also optionally would it be possible to list the current versions of all the packages (or the selected ones) and have the Update Manager program check for newer versions and then display both the currently installed version number and the newer version that's available from the internet. Providing the ability to download and install to the latest versions would also help as well.


Version-Release number of selected component (if applicable):
system-config-packages-1.2.25-1.noarch

How reproducible:
Always

Steps to Reproduce:
1a. For Knoppix shell, select the Redhat Menu, then select 'Server Settings' then 'Add/Remove Applications'.
1b. For Gnome shell, select the 'Desktop' menu from the top, then select 'Server Settings' and then 'Add/Remove Applications'.


Additional info:

Comment 1 Jeremy Katz 2005-10-26 16:10:43 UTC

*** This bug has been marked as a duplicate of 171688 ***


Note You need to log in before you can comment on or make changes to this bug.