Bug 1717093 - Overcloud nodes registered to Satellite 6.5 show Warning status: Could not calculate errata status, ensure host is registered and the katello-host-tools package is installed
Summary: Overcloud nodes registered to Satellite 6.5 show Warning status: Could not ca...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ansible-role-redhat-subscription
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: rc
: 15.0 (Stein)
Assignee: Emilien Macchi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-04 16:52 UTC by Marius Cornea
Modified: 2019-09-26 10:51 UTC (History)
8 users (show)

Fixed In Version: ansible-role-redhat-subscription-1.0.3-0.20190606020403.a8b5d81.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:22:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 663328 0 None MERGED sat6: install katello-host-tools after registration 2021-02-03 09:37:09 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:23:10 UTC

Description Marius Cornea 2019-06-04 16:52:10 UTC
Description of problem:

Overcloud nodes registered to Satellite 6.5 show Warning status: Could not calculate errata status, ensure host is registered and the katello-host-tools package is installed

Version-Release number of selected component (if applicable):
ansible-role-container-registry-1.0.1-0.20190424010422.b54b8ac.el8ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP15 overcloud with nodes registered to Satellite 6.5

Actual results:
Deployment succeeds but nodes registered to Satellite show Warning status with Erata property: Could not calculate errata status, ensure host is registered and the katello-host-tools package is installed

Expected results:
Nodes show OK status.

Additional info:
Nodes report OK status after manually installing katello-host-tools package.

Comment 1 Luke Short 2019-06-04 20:42:59 UTC
Is katello-host-tools installed on the Overcloud nodes before the deployment? That is not a package that RHOSP would manage.

Comment 4 Marius Cornea 2019-06-04 20:54:30 UTC
(In reply to Luke Short from comment #1)
> Is katello-host-tools installed on the Overcloud nodes before the
> deployment? That is not a package that RHOSP would manage.

It's not - the nodes get provisioned during deployment and the package is not present in the overcloud image. Since we're doing the registration via Director I don't think this is a Satellite bug.

Comment 11 errata-xmlrpc 2019-09-21 11:22:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.