Bug 171720 - setarch i386 doesn't work with yum
setarch i386 doesn't work with yum
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-25 12:13 EDT by Dawid Zamirski
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 12:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Zamirski 2005-10-25 12:13:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Description of problem:
Hello

I wanted to use the setarch command to make yum use i386 repositories instead of x86_64. This is needed when you want to resolve the issues with 32bit plugins and Firefox. My repositories are configured to use $basearch variable, and from what I have found on google, this variable is taken from uname -m output. Since setarch affects this output yum should also use relevant repositories, but it sill uses x86_64 although setarch was set to i386.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set all repositories to use $basearch var in place of architecture in .repo files
2. setarch i386 yum update
3. yum still uses x86_64..
  

Actual Results:  yum uses x86_64 instwad of what was set via setarch command

Expected Results:  yum should use architecure whatever was set by setarch

Additional info:

uname -m gives x86_64

setarch i386 uname -m gives i686 (not 386, but in this case yum should at least to fail to retrieve repomd.xml instead of using x86_64)
Comment 1 Jeremy Katz 2005-10-26 12:17:05 EDT
If you have an /etc/rpm/platform (which you will by default), rpmlib will use
this over whatever it can derive via uname.

Note You need to log in before you can comment on or make changes to this bug.