Bug 171722 - console: build.xml has hardcoded reference to root directory
Summary: console: build.xml has hardcoded reference to root directory
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Directory Console   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-25 16:41 UTC by Rich Megginson
Modified: 2015-01-04 23:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-06 19:45:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs for fix (3.73 KB, text/plain)
2005-10-25 16:41 UTC, Rich Megginson
no flags Details

Description Rich Megginson 2005-10-25 16:41:32 UTC
In gar and rpm build land, the console.root directory may not be "console" it
may be something like "fedora-console-7.1.1".  So, it's better to have
console.root be "." and reference imports and built like 
built.dir = ${console.root}/../built

Comment 1 Rich Megginson 2005-10-25 16:41:33 UTC
Created attachment 120372 [details]
diffs for fix

Comment 2 Rich Megginson 2005-10-25 17:29:30 UTC
Reviewed by: nkinder@redhat.com nhosoi@redhat.com (Thanks!)
Files: build.xml, build.properties
Branch: HEAD
Fix Description: Use "." instead of ".." as the console.root.  This 
allows us to use console.root/buildnum.pl instead of 
console.root/console/buildnum.pl.  The imports and built dirs are 
referenced by console.root/../built e.g.  The problem is that when 
building from a source tar ball in rpm or gar, it expects the source 
directory when unpacked to be the same name as the .tar.gz file e.g. 
fedora-console-7.1.1.tar.gz unpacks into fedora-console-7.1.1.  If 
"/console/" is hard coded, this won't work.
Platforms tested: RHEL4
Flag Day: no
Doc impact: no

Checking in build.properties;
/cvs/dirsec/console/build.properties,v  <--  build.properties
new revision: 1.5; previous revision: 1.4
done
Checking in build.xml;
/cvs/dirsec/console/build.xml,v  <--  build.xml
new revision: 1.7; previous revision: 1.6
done



Note You need to log in before you can comment on or make changes to this bug.