Bug 171723 - vsftpd with TLS enabled gives error after Update 2
vsftpd with TLS enabled gives error after Update 2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vsftpd (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Maros Barabas
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-25 12:48 EDT by Johnn Tan
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 2.0.1-5.EL4.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-09 03:09:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnn Tan 2005-10-25 12:48:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Prior to update, I had vsftpd running fine with TLS. This was enabled in /etc/vsftpd/vsftpd.conf:
ssl_enable=YES

After upgrade, vsftpd 2.0.1-5 was replaced with 2.0.1-5.EL4.3. Connecting to ftp then fails for all users, as follows (real domain and IP address replaced):

===
                *** CuteFTP 7.0 - build Mar 10 2005 ***

STATUS:> Getting listing ""...
STATUS:> Resolving host name ftp.example.com...
STATUS:> Host name ftp.example.com resolved: ip = 10.10.10.10.
STATUS:> Connecting to FTP server
ftp.example.com:21 (ip = 10.10.10.10)...
STATUS:> Socket connected. Waiting for welcome message...
                220 Welcome to ftp server.
STATUS:> Connected. Authenticating...
COMMAND:> AUTH TLS
                234 Proceed with negotiation.
STATUS:> Establishing SSL session.
STATUS:> Initializing SSL module.
STATUS:> Connected. Exchanging encryption keys...
                Session Cipher: 128 bit RC2
STATUS:> SSL Connect time: 241 ms.
STATUS:> SSL encrypted session established.
COMMAND:> PBSZ 0
                200 PBSZ set to 0.
COMMAND:> USER bstest
                331 Please specify the password.
COMMAND:> PASS *****
ERROR:> Can't read from control socket. Socket error = 0.

===

Reverting back to version 2.0.1-5 resolves the issue.

Version-Release number of selected component (if applicable):
2.0.1-5.EL4.3

How reproducible:
Didn't try

Steps to Reproduce:
1. Setup vsftpd 2.0.1-5 with "ssl_enabled=YES" in /etc/vsftpd/vsftpd.conf.
2. Update to vsftpd 2.0.1-5.EL4.3.
3. Connect with TLS-aware client, such as CuteFTP.


Actual Results:  Get error message saying:
ERROR:> Can't read from control socket. Socket error = 0.

Cannot proceed after that.

Expected Results:  Should connect to FTP server and see directory listing.

Additional info:
Comment 1 Radek Vokal 2006-03-20 02:36:03 EST
Strangely I can't reproduce the issue. Also I went through the patches I added
to the RHEL4 version and there shouldn't be changes related to this (there were
mainly changes related to new pam module). New RHEL4 Update will bring you
vsftpd-2.0.1-5.EL4.4. Please retest with this package. 
Comment 2 Johnn Tan 2006-05-03 23:03:26 EDT
This new version (pulled from fasttrack, as Update 4 does not seem to be ready)
appears to have resolved the problem. Thank you!
Comment 3 Radek Vokal 2006-08-09 03:09:13 EDT
This bug has been fixed in RHEL4 Update 4. 

Note You need to log in before you can comment on or make changes to this bug.