Bug 1717623 - OLM installed operators are not getting new version numbers in the release pipeline
Summary: OLM installed operators are not getting new version numbers in the release pi...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.z
Assignee: Tim Bielawa
QA Contact: Mike Fiedler
URL:
Whiteboard: 4.1.3
Depends On:
Blocks: 1718956
TreeView+ depends on / blocked
 
Reported: 2019-06-05 20:04 UTC by Jessica Forrester
Modified: 2019-10-24 03:17 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1717627 (view as bug list)
Environment:
Last Closed: 2019-06-13 20:49:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jessica Forrester 2019-06-05 20:04:21 UTC
The ClusterServiceVersions for:
Template Service Broker Operator
Ansible Service Broker Operator
Cluster Logging Operator
ElasticSearch Operator

are not being automatically updated in the ART release pipeline with new version numbers, this means we would not be able to upgrade existing installed operators that went out with 4.1.0

Because the automation is not there we are manually updating the 4 operators to have a 4.1.1 version number.

See:
https://github.com/openshift/elasticsearch-operator/pull/151
https://github.com/openshift/template-service-broker-operator/pull/44
https://github.com/openshift/ansible-service-broker/pull/1226
https://github.com/openshift/cluster-logging-operator/pull/196

When these are merged we should be able to update from a 4.1.0 installed operator to the 4.1.1 version of the operator.

Note: this is a one-off fix for 4.1.1, we may have to do the same for 4.1.2 but we will be automating this as soon as possible.

Comment 1 Sudha Ponnaganti 2019-06-06 04:26:03 UTC
Merged

Comment 5 Mike Fiedler 2019-06-07 15:22:12 UTC
verified on 4.1.0-0.ci-2019-06-06-142449.   Following the internal instructions for testing the latest down stream OperatorHub operators:

- clusterlogging, elasticsearch, ASB and TSB operators show 4.1.1 in the catalog
- previously installed 4.1.0 operators upgraded successfully to 4.1.1 according to Automatic or Manual policy

Comment 6 Sudha Ponnaganti 2019-06-12 17:51:15 UTC
Why Need Info ? in the title


Note You need to log in before you can comment on or make changes to this bug.