Bug 1717631 - clusteroperator/cloud-credential does not define any related resources
Summary: clusteroperator/cloud-credential does not define any related resources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Devan Goodwin
QA Contact: Oleg Nesterov
URL:
Whiteboard:
: 1715638 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-05 20:32 UTC by Luis Sanchez
Modified: 2019-10-16 06:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Cloud credential operator ClusterOperator did not define related resources. Consequence: Cloud credential operator logs not present in oc adm must-gather tarball. Fix: Added related resources. Result: Logs now included.
Clone Of:
Environment:
Last Closed: 2019-10-16 06:31:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:31:47 UTC

Description Luis Sanchez 2019-06-05 20:32:03 UTC
Description of problem:

The cloud-credential ClusterOperator resource does not specify any related resources. This hinders problem-determination as tools cannot automatically collect the information needed to debug issues.

The cloud-credential operator should specify, at minimum, a namespace and a configuration resource to collect.

Here is an example from kube-apisever:

kind: ClusterOperator
metadata:
  name: kube-apiserver
status:
  relatedObjects:
    - group: operator.openshift.io
      name: cluster
      resource: kubeapiservers
    - group: ''
      name: openshift-config
      resource: namespaces
    - group: ''
      name: openshift-config-managed
      resource: namespaces
    - group: ''
      name: openshift-kube-apiserver-operator
      resource: namespaces
    - group: ''
      name: openshift-kube-apiserver
      resource: namespaces


A new e2e test designed to catch this deficiency will whitelist this component initially. This component should be removed from the whitelist as part of resolving this issue.

https://github.com/openshift/origin/blob/master/test/extended/operators/clusteroperators.go (link will be active once https://github.com/openshift/origin/pull/23044 merges)

Comment 1 Devan Goodwin 2019-06-27 15:02:44 UTC
*** Bug 1715638 has been marked as a duplicate of this bug. ***

Comment 3 Oleg Nesterov 2019-08-02 14:58:18 UTC
Tested on 4.2.0-0.nightly-2019-08-01-113533

found next logs by running oc adm must-gather

2019/08/02 14:53:37     Gathering related object reference information for ClusterOperator "cloud-credential"...
2019/08/02 14:53:37     Found related object "namespaces/openshift-cloud-credential-operator" for ClusterOperator "cloud-credential"...
2019/08/02 14:53:37 Gathering data for ns/openshift-cloud-credential-operator...
2019/08/02 14:53:37     Collecting resources for namespace "openshift-cloud-credential-operator"...
2019/08/02 14:53:37     Gathering pod data for namespace "openshift-cloud-credential-operator"...
2019/08/02 14:53:37         Gathering data for pod "cloud-credential-operator-6c897f8cc4-cb297"

and 

[onest@localhost ~]$ oc get clusteroperator cloud-credential -o yaml
apiVersion: config.openshift.io/v1
kind: ClusterOperator
metadata:
  creationTimestamp: "2019-08-02T11:09:54Z"
  generation: 1
  name: cloud-credential
  resourceVersion: "2977"
  selfLink: /apis/config.openshift.io/v1/clusteroperators/cloud-credential
  uid: 0e2ca687-b516-11e9-b675-0ed394d5f5b4
spec: {}
status:
  conditions:
  - lastTransitionTime: "2019-08-02T11:10:01Z"
    message: No credentials requests reporting errors.
    reason: NoCredentialsFailing
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-08-02T11:10:01Z"
    message: 4 of 4 credentials requests provisioned and reconciled.
    reason: ReconcilingComplete
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-08-02T11:09:54Z"
    status: "True"
    type: Available
  - lastTransitionTime: "2019-08-02T11:09:54Z"
    status: "True"
    type: Upgradeable
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-cloud-credential-operator
    resource: namespaces
  versions:
  - name: operator
    version: 4.2.0-0.nightly-2019-08-01-113533

Comment 5 errata-xmlrpc 2019-10-16 06:31:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.