Bug 171767 - LD_DEBUG_OUTPUT ignored by "conflict processing"
LD_DEBUG_OUTPUT ignored by "conflict processing"
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-25 23:02 EDT by John Reiser
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-02 07:52:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2005-10-25 23:02:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Setting the environment variable LD_DEBUG_OUTPUT to a pathname should capture all LD_DEBUG output to that file.  However, the line "conflict processing: <executable>" and its preceding blank line go to stdout instead of to the named file.

Version-Release number of selected component (if applicable):
binutils-2.15.94.0.2.2-2.1

How reproducible:
Always

Steps to Reproduce:
1. LD_DEBUG_OUTPUT=foo LD_DEBUG=all date
2.
3.
  

Actual Results:  $ LD_DEBUG_OUTPUT=foo LD_DEBUG=all date

conflict processing: date
Tue Oct 25 19:57:51 PDT 2005
$ 

Expected Results:  $ LD_DEBUG_OUTPUT=foo LD_DEBUG=all date
Tue Oct 25 19:57:51 PDT 2005
$ 

Additional info:
Comment 1 John Reiser 2005-10-26 10:50:43 EDT
Oops, the problem is in rtld, not /usr/bin/ld.  The component version is
glibc-2.3.5-10.3 .
Comment 2 Jakub Jelinek 2005-11-02 07:52:47 EST
Fixed on upstream glibc CVS HEAD, will appear in rawhide whenever a new built
will be done.

Note You need to log in before you can comment on or make changes to this bug.