Bug 1717700 - Regeneration of ueber certificate is causing optimized capsule sync to perform force full sync every time.
Summary: Regeneration of ueber certificate is causing optimized capsule sync to perfor...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Capsule - Content
Version: 6.4.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 6.4.4
Assignee: satellite6-bugs
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-05 23:39 UTC by Mike McCune
Modified: 2019-10-30 17:09 UTC (History)
15 users (show)

Fixed In Version: tfm-rubygem-katello-3.7.0.57-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1705099
Environment:
Last Closed: 2019-07-15 15:10:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 26721 High Closed Regeneration of ueber certificate is causing optimized capsule sync to perform force full sync every time 2020-04-30 08:06:26 UTC
Red Hat Product Errata RHBA-2019:1780 None None None 2019-07-15 15:10:30 UTC

Comment 5 Lukas Pramuk 2019-07-11 17:13:59 UTC
VERIFIED.

@satellite-6.4.4-2.el7sat.noarch
tfm-rubygem-katello-3.7.0.58-1.el7sat.noarch

by the following manual reproducer:


1) Have Satellite & Capsule 6.4.3 installed with custom certs

2) Sync a bunch of large yum repos (rhel7/rhel6 server) on Satellite with the external capsule

3) Trigger capsule sync tasks and note the time

# time hammer capsule content synchronize --id 2

>>> times [ ~29min, 16min, 15min ... ] there is performance issue (doing fullsyncs all the time)

4) Upgrade Satellite and Capsule to 6.4.4 candidate

5) Trigger capsule sync tasks and note the time

>>> times [ 29sec, 16sec, 15sec ]  the fix resolves the perf issue (doing optimized syncs)

Comment 7 errata-xmlrpc 2019-07-15 15:10:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1780


Note You need to log in before you can comment on or make changes to this bug.