Bug 171772 - Missing .so symlinks in libgcj4-devel package
Missing .so symlinks in libgcj4-devel package
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc4 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-26 04:41 EDT by Panu Matilainen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 04:45:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu Matilainen 2005-10-26 04:41:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
libgcj4-devel package doesn't include .so symlinks to the actual libraries, which causes builds to miserably fail.

Version-Release number of selected component (if applicable):
libgcj4-devel-4.0.1-4.EL4.2

How reproducible:
Always

Steps to Reproduce:
1. Try to build something with gcj4 (OOo2 based on FC-devel spec in this case)

  

Actual Results:  ...
checking for JAWT_GetAWT in -lgcjawt... no


Expected Results:  It should find the library...

Additional info:

Adding the following symlinks manually appears to fix it:
cd /usr/lib
ln -s libgcj.so.6.0.0 libgcj.so
ln -s libgcjawt.so.6.0.0 libgcjawt.so
ln -s libgij.so.6.0.0 libgij.so
ln -s lib-gnu-java-awt-peer-gtk.so.6.0.0 lib-gnu-java-awt-peer-gtk.so
Comment 1 Jakub Jelinek 2005-10-26 04:45:47 EDT
They are in the gcc-java package:
rpm -qplv gcc-java-3.4.4-2.i386.rpm | grep '\.so'
lrwxrwxrwx    1 root    root               43 Jul 25 06:51
/usr/lib/gcc/i386-redhat-linux/3.4.3/lib-gnu-java-awt-peer-gtk.so ->
../../../lib-gnu-java-awt-peer-gtk.so.5.0.0
lrwxrwxrwx    1 root    root               33 Jul 25 06:51
/usr/lib/gcc/i386-redhat-linux/3.4.3/lib-org-w3c-dom.so ->
../../../lib-org-w3c-dom.so.5.0.0
lrwxrwxrwx    1 root    root               33 Jul 25 06:51
/usr/lib/gcc/i386-redhat-linux/3.4.3/lib-org-xml-sax.so ->
../../../lib-org-xml-sax.so.5.0.0
lrwxrwxrwx    1 root    root               24 Jul 25 06:51
/usr/lib/gcc/i386-redhat-linux/3.4.3/libgcj.so -> ../../../libgcj.so.5.0.0
Comment 2 Panu Matilainen 2005-10-26 05:03:33 EDT
Oh, ok .. I only looked at libgcj4-devel since that's where they are in FC4
packages, clearly the links are there now that I know where to look for:

rpm -ql gcc4-java|grep .so
/usr/lib/gcc/i386-redhat-linux/4.0.1/lib-gnu-java-awt-peer-gtk.so
/usr/lib/gcc/i386-redhat-linux/4.0.1/libgcj.so
/usr/lib/gcc/i386-redhat-linux/4.0.1/libgcjawt.so
/usr/lib/gcc/i386-redhat-linux/4.0.1/libgij.so

Looking at strace of the build a bit closer reveals that it's looking in wrong
gcc-directory:
9203  open("/usr/lib/libgcjawt.so", O_RDONLY) = -1 ENOENT (No such file or
directory)
9203  open("/usr/lib/libgcjawt.a", O_RDONLY) = -1 ENOENT (No such file or directory)
9203  open("/usr/lib/gcc/i386-redhat-linux/3.4.4/libgcjawt.so", O_RDONLY) = -1
ENOENT (No such file or directory)
9203  open("/usr/lib/gcc/i386-redhat-linux/3.4.4/libgcjawt.a", O_RDONLY) = -1
ENOENT (No such file or directory)

So .. I suppose this is "just" a ooo-build problem.. never mind then, sorry
about the false alarm :)

Note You need to log in before you can comment on or make changes to this bug.