Bug 1717754 - Enable features.locks-notify-contention by default
Summary: Enable features.locks-notify-contention by default
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: locks
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1720488
TreeView+ depends on / blocked
 
Reported: 2019-06-06 06:28 UTC by Xavi Hernandez
Modified: 2019-06-26 06:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1720488 (view as bug list)
Environment:
Last Closed: 2019-06-26 06:05:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22828 None Merged locks: enable notify-contention by default 2019-06-26 06:05:20 UTC

Description Xavi Hernandez 2019-06-06 06:28:32 UTC
Description of problem:

Currently 'features.locks-notify-contention' is disabled by default. This option, when enabled, instructs the locks xlator to send an upcall notification to the current owner of a lock whenever another client tries to acquire a conflicting lock.

Both AFR and EC support this notification and react by releasing the lock as soon as possible. This is extremely useful when eager-lock is enabled (it is by default) because it allows AFR and EC to use it to improve performance but we don't loose performance on other clients when access to the same resource is required.

Since eager-lock is enabled by default, it doesn't make sense to keep contention notification disabled.

Version-Release number of selected component (if applicable): mainline


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-06-06 06:31:15 UTC
REVIEW: https://review.gluster.org/22828 (locks: enable notify-contention by default) posted (#1) for review on master by Xavi Hernandez

Comment 2 Worker Ant 2019-06-26 06:05:22 UTC
REVIEW: https://review.gluster.org/22828 (locks: enable notify-contention by default) merged (#4) on master by Pranith Kumar Karampuri


Note You need to log in before you can comment on or make changes to this bug.