Bug 171776 - missing buildrequirement for 32bit glibc
missing buildrequirement for 32bit glibc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-26 06:13 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.97-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-04 12:03:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-10-26 06:13:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
grub fails to build on a x86_64 machine:
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

in config.log:
configure:2425: gcc -m32 -Os -g -fno-strict-aliasing -Wall -Werror -Wno-shadow -Wno-pointer-sign -static   conftest.c  >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status



Version-Release number of selected component (if applicable):
grub-0.95-15

How reproducible:
Always

Steps to Reproduce:
1.try to build grub on a 64bit machine
2.
3.
  

Actual Results:  -m32 implies /usr/lib/crt1.o, having /usr/lib64/crt1.o from the 64bit glibc isn't sufficient

Additional info:
Comment 1 Mark McLoughlin 2007-07-04 12:03:49 EDT
It's had:

  BuildRequires: /usr/lib/crt1.o

since 0.97-7, so this is likely well fixed now. Please do re-open if not.

Note You need to log in before you can comment on or make changes to this bug.