Bug 1717819 - Changes to self-heal logic w.r.t. detecting metadata split-brains
Summary: Changes to self-heal logic w.r.t. detecting metadata split-brains
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karthik U S
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-06 09:21 UTC by Karthik U S
Modified: 2019-06-10 14:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 14:48:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22831 None Merged Cluster/afr: Don't treat all bricks having metadata pending as split-brain 2019-06-10 14:48:45 UTC

Description Karthik U S 2019-06-06 09:21:37 UTC
Description of problem:

We currently don't have a roll-back/undoing of post-ops if quorum is not met. Though the FOP is still unwound with failure, the xattrs remain on the disk. Due to these partial post-ops and partial heals (healing only when 2 bricks are up), we can end up in metadata split-brain purely from the afr xattrs point of view i.e each brick is blamed by atleast one of the others for metadata. These scenarios are hit when there is frequent connect/disconnect of the client/shd to the bricks.

Comment 1 Worker Ant 2019-06-06 09:34:30 UTC
REVIEW: https://review.gluster.org/22831 (Cluster/afr: Don't treat all bricks having metadata pending as split-brain) posted (#1) for review on master by Karthik U S

Comment 2 Worker Ant 2019-06-10 14:48:46 UTC
REVIEW: https://review.gluster.org/22831 (Cluster/afr: Don't treat all bricks having metadata pending as split-brain) merged (#5) on master by Amar Tumballi


Note You need to log in before you can comment on or make changes to this bug.