Bug 1717865 - pkcon download from file:// repository does not work
Summary: pkcon download from file:// repository does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: libdnf
Version: 8.2
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: 8.0
Assignee: amatej
QA Contact: Eva Mrakova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-06 11:29 UTC by Jan Blazek
Modified: 2020-04-28 16:48 UTC (History)
2 users (show)

Fixed In Version: libdnf-0.39.1-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:47:49 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:48:03 UTC

Description Jan Blazek 2019-06-06 11:29:21 UTC
Description of problem:
Downloading a package with "pkcon download" from yum repository with baseurl defined with file:// protocol does not work.

On the other hand "yum download" can download from file:// repositories. It would be nice if this functionality was consistent across both yum (dnf) and PackageKit.

Version-Release number of selected component (if applicable):
PackageKit-1.1.12-2.el8.x86_64
librepo-1.9.2-1.el8.x86_64
libdnf-0.22.5-4.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1. create simple file:// repository with some "foo" package
2. pkcon download . foo

Actual results:
[..]
Fatal error: Refusing to download from local repository "file"
echo $?
7

Expected results:
The package is downloaded.

Comment 1 Richard Hughes 2019-07-31 08:57:23 UTC
This is from libdnf/dnf-repo.cpp, reassigning.

Comment 2 amatej 2019-11-01 15:55:52 UTC
I created a PR that should fix this:
https://github.com/rpm-software-management/libdnf/pull/833

Comment 7 errata-xmlrpc 2020-04-28 16:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.