Bug 1717940 - py3 librados get_fsid() function returns bytes instead of a string
Summary: py3 librados get_fsid() function returns bytes instead of a string
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 4.0
Assignee: Jason Dillaman
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks: 1594251
TreeView+ depends on / blocked
 
Reported: 2019-06-06 13:49 UTC by Lee Yarwood
Modified: 2020-01-31 12:46 UTC (History)
16 users (show)

Fixed In Version: ceph-14.2.1-508.g0f9d32b.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:46:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 38381 0 None None None 2019-06-06 14:05:48 UTC
Github ceph ceph pull 26514 0 'None' closed pybind/rados: fixed Python3 string conversion issue on get_fsid 2020-01-23 20:25:13 UTC
Github ceph ceph pull 28476 0 'None' closed nautilus: Rados.get_fsid() returning bytes in python3 2020-01-23 20:25:14 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:41 UTC

Description Lee Yarwood 2019-06-06 13:49:53 UTC
Description of problem:
This has been reported against openstack/cinder upstream in the following bug:

Acceleration cinder - glance with ceph not working
https://bugs.launchpad.net/cinder/+bug/1816468

With a workaround landing recently for this:

Fix python3 compatibility of rbd get_fsid
https://review.opendev.org/#/c/635195/

This was also fixed in ceph itself and backported to some older releases but doesn't appear present in the bits used by OSP 15:

https://github.com/ceph/ceph/pull/27259
http://tracker.ceph.com/issues/38872

Version-Release number of selected component (if applicable):
14.2.1-0

How reproducible:
Always

Steps to Reproduce:
1. call get_fsid

Actual results:
bytes returned.

Expected results:
string returned.

Additional info:

Comment 14 Giridhar Ramaraju 2019-08-05 13:09:10 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 15 Giridhar Ramaraju 2019-08-05 13:10:30 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 19 errata-xmlrpc 2020-01-31 12:46:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.