Bug 171798 - support establishing network connection upon boot
support establishing network connection upon boot
Status: CLOSED DUPLICATE of bug 154652
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-26 12:06 EDT by Myk Melez
Modified: 2008-02-12 09:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 09:41:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Myk Melez 2005-10-26 12:06:29 EDT
NetworkManager doesn't establish a network connection until a user logs in, but
services started on boot like ntpd and sshd have legitimate uses for a network
connection upon start.  NetworkManager should store network connection
configuration in a user-neutral location by default or when requested to do so
by the user and connect to a user-neutral network connection on boot when one is
available.
Comment 1 W. Michael Petullo 2005-11-21 20:11:23 EST
I am interested in the same functionality.

However, I have what seems to be a catch-22.  NetworkManager requires dbus. 
Dbus seems to make LDAP requests when LDAP is used for NSS (for /etc/hosts?) 
These requests hang if the network is not available.

So, which starts first: dbus or NetworkManager?

I am using dbus-0.50-1, NetworkManager-0.5.1-4 and glibc-2.3.90-18.

Because of this, I have had to use netplugd to manage my network device.
Comment 2 Douglas Furlong 2006-02-09 04:46:02 EST
What happens in casses when there isn't a "user neutral" option?

I would personally be more interested in a method, that allowed network services
to detect that the network is not up, and as such not attempt to load.
Comment 3 quintesse 2006-03-03 16:54:57 EST
If there isn't a "user neutral" option those services should be made smarter,
but that's an entirely different set of problems.

What is described here is that there _is_ a network out there, NM just won't
connect to it until somebody logs in.  There should be an option saying: if
network X is available, this is the key for it, use it!

We've got several wireless machines in this house and 90% of the time they will
be used here and nowhere else, having to log in to get them conencted is a nuisance.
Comment 4 Dan Williams 2008-02-12 09:41:03 EST

*** This bug has been marked as a duplicate of 154652 ***

Note You need to log in before you can comment on or make changes to this bug.