Bug 1718192 - systemd-networkd bug makes it incompatible with kernel > 5.2.0-0.rc2.git1.2.fc31.x86_64
Summary: systemd-networkd bug makes it incompatible with kernel > 5.2.0-0.rc2.git1.2.f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1732176 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-07 08:23 UTC by Nicolas Mailhot
Modified: 2019-08-05 21:07 UTC (History)
29 users (show)

Fixed In Version: systemd-243~rc1-1.fc31 systemd-241-10.git511646b.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-04 01:13:39 UTC
Type: Bug


Attachments (Terms of Use)
Working kernel dmesg (5.2.0-0.rc2.git1.2.fc31.x86_64) (113.89 KB, text/plain)
2019-06-07 08:23 UTC, Nicolas Mailhot
no flags Details
Working kernel networkd (5.2.0-0.rc2.git1.2.fc31.x86_64) (1.39 KB, text/plain)
2019-06-07 08:24 UTC, Nicolas Mailhot
no flags Details
Failing kernel dmesg (5.2.0-0.rc3.git1.1.fc31.x86_64) (3.07 KB, text/plain)
2019-06-07 08:24 UTC, Nicolas Mailhot
no flags Details
Failing kernel networkd (5.2.0-0.rc3.git1.1.fc31.x86_64) (3.07 KB, text/plain)
2019-06-07 08:28 UTC, Nicolas Mailhot
no flags Details
Failing kernel dmesg (5.2.0-0.rc3.git2.1.fc31.x86_64) (2.17 KB, text/plain)
2019-06-07 08:29 UTC, Nicolas Mailhot
no flags Details
Failing kernel networkd (5.2.0-0.rc3.git2.1.fc31.x86_64) (2.17 KB, text/plain)
2019-06-07 08:29 UTC, Nicolas Mailhot
no flags Details
Failing kernel dmesg (5.2.0-0.rc3.git1.1.fc31.x86_64) (115.65 KB, text/plain)
2019-06-09 08:27 UTC, Nicolas Mailhot
no flags Details
Failing kernel dmesg (5.2.0-0.rc3.git2.1.fc31.x86_64) (114.98 KB, text/plain)
2019-06-09 08:28 UTC, Nicolas Mailhot
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 203769 0 None None None 2019-08-04 09:38:09 UTC

Description Nicolas Mailhot 2019-06-07 08:23:12 UTC
Created attachment 1578275 [details]
Working kernel dmesg (5.2.0-0.rc2.git1.2.fc31.x86_64)

vanilla rawhide kernel > 5.2.0-0.rc2.git1.2.fc31.x86_64 breaks bonding

the exact same setup reboots fine with kernel  5.2.0-0.rc2.git1.2.fc31.x86_64

Comment 1 Nicolas Mailhot 2019-06-07 08:24:01 UTC
Created attachment 1578276 [details]
Working kernel networkd (5.2.0-0.rc2.git1.2.fc31.x86_64)

Comment 2 Nicolas Mailhot 2019-06-07 08:24:44 UTC
Created attachment 1578277 [details]
Failing kernel dmesg (5.2.0-0.rc3.git1.1.fc31.x86_64)

Comment 3 Nicolas Mailhot 2019-06-07 08:28:14 UTC
Created attachment 1578278 [details]
Failing kernel networkd (5.2.0-0.rc3.git1.1.fc31.x86_64)

Comment 4 Nicolas Mailhot 2019-06-07 08:29:11 UTC
Created attachment 1578279 [details]
Failing kernel dmesg (5.2.0-0.rc3.git2.1.fc31.x86_64)

Comment 5 Nicolas Mailhot 2019-06-07 08:29:52 UTC
Created attachment 1578280 [details]
Failing kernel networkd (5.2.0-0.rc3.git2.1.fc31.x86_64)

Comment 6 Yanko Kaneti 2019-06-09 01:51:02 UTC
This  https://bugzilla.kernel.org/show_bug.cgi?id=203769

Comment 7 Nicolas Mailhot 2019-06-09 08:27:03 UTC
Created attachment 1578764 [details]
Failing kernel dmesg (5.2.0-0.rc3.git1.1.fc31.x86_64)

Comment 8 Nicolas Mailhot 2019-06-09 08:28:06 UTC
Created attachment 1578765 [details]
Failing kernel dmesg (5.2.0-0.rc3.git2.1.fc31.x86_64)

Comment 9 Nicolas Mailhot 2019-06-09 08:45:07 UTC
@Yanko Kaneti: thanks for the link, I added myself there too

Comment 10 Yanko Kaneti 2019-06-12 11:02:24 UTC
Doesn't look like the kernel side would be willing to revert to the more lenient behavior from before.

https://lore.kernel.org/netdev/58ac6ec1-9255-0e51-981a-195c2b1ac380@mellanox.com/

Lets move this to systemd which should be fixed by picking up at least:
https://github.com/systemd/systemd/commit/4eb086a38712ea98faf41e075b84555b11b54362

Comment 11 Nicolas Mailhot 2019-06-21 08:12:55 UTC
So, is

Comment 12 Justin M. Forbes 2019-07-09 15:37:19 UTC
We will need those fixes backported to F29 and F30 if possible.

Comment 13 Tomasz Torcz 2019-07-11 19:07:59 UTC
Upstream bug is https://github.com/systemd/systemd/issues/12784, it is fixed by 4eb086a (mentioned in c#10) and 9f6e82e.

Comment 14 Zbigniew Jędrzejewski-Szmek 2019-07-21 09:33:42 UTC
The first commit is in systemd-242-5.git7a6d834.fc31, but I missed the second one.

Comment 15 Morten Stevens 2019-07-22 10:28:11 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #14)
> The first commit is in systemd-242-5.git7a6d834.fc31, but I missed the
> second one.

Thank you. I did a quick test and systemd-networkd works again with kernel-5.2.x

Test environment
Fedora 31 (rawhide)
kernel-5.2.0-1.fc31.x86_64
systemd-242-6.git9d34e79.fc31.x86_64

Comment 16 Tomasz Torcz 2019-07-22 14:39:19 UTC
It doesn't work for me with systemd-241-9.gitb67ecf2.fc30.x86_64. Is the patch really backported?

Comment 17 Zbigniew Jędrzejewski-Szmek 2019-07-22 14:50:36 UTC
It wasn't in 241-9. I pushed 07f0549ffe3413f0e78b656dd34d64681cbd8f00 and 8fbc72f45f4aa84889bc8694a9ce662946464c37 to v241-stable branch upstream. They'll go out in the next update in Fedora.

Comment 18 Hristo Venev 2019-07-25 21:59:55 UTC
When will that next update happen?

Comment 19 Zbigniew Jędrzejewski-Szmek 2019-07-30 20:35:31 UTC
Built in rawhide.

Comment 20 Zbigniew Jędrzejewski-Szmek 2019-08-02 07:52:32 UTC
After looking at the code in systemd-239, it seems to me that a patch is not needed there. If somebody
sees the issue in Fedora29, please let me know. I'll reopen this for F30.

Comment 21 Fedora Update System 2019-08-02 12:19:32 UTC
FEDORA-2019-5019dd35f8 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5019dd35f8

Comment 22 Fedora Update System 2019-08-03 00:58:18 UTC
systemd-241-10.git511646b.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5019dd35f8

Comment 23 Fedora Update System 2019-08-04 01:13:39 UTC
systemd-241-10.git511646b.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Zbigniew Jędrzejewski-Szmek 2019-08-05 21:07:47 UTC
*** Bug 1732176 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.