Bug 17182 - spec file problem with nsswitch.conf
spec file problem with nsswitch.conf
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-01 13:01 EDT by Rod m. Stewart
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-01 13:01:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rod m. Stewart 2000-09-01 13:01:23 EDT
In the glibc spec file make the following change.  I'm not certain where
you are picking up nsswitch.conf from, but I do not have a redhat directory
in my glibc tree...
	s|redhat/nsswitch.conf|nss/nsswitch.conf|
This is in the current Rawhide and RC1 source.  The offending line is:
  install -m 644 redhat/nsswitch.conf $RPM_BUILD_ROOT/etc/nsswitch.conf
Comment 1 Jakub Jelinek 2000-09-04 04:55:54 EDT
If you're building your own glibc, you'll have to modify glibc.spec not only
because of this but for a couple of different things as well.
The tarball we're shipping in glibc source rpm is a snapshot from our internal
glibc CVS, which is basically a sourceware snapshot + diff-CYGNUS-to-REDHAT.patch
applied plus a few new directories (like c-stubs, glibc-compat and redhat).

Note You need to log in before you can comment on or make changes to this bug.