Bug 171844 - [kde] OpenOffice crash pasting slides from one presentation to another
[kde] OpenOffice crash pasting slides from one presentation to another
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-26 19:01 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.1-143.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 04:20:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
source presentation (7.02 MB, application/octet-stream)
2005-10-27 12:48 EDT, Orion Poplawski
no flags Details
target presentation (4.32 MB, application/octet-stream)
2005-10-27 12:49 EDT, Orion Poplawski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 25199 None None None Never
OpenOffice.org 51738 None None None Never

  None (edit)
Description Orion Poplawski 2005-10-26 19:01:22 EDT
Description of problem:
One of my users had a crash when pasting slides from one presentation into another.

Here's the trace.

0x37f028: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e028
0x37f7ee: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e7ee
0x59d420:  + 0x420 (__kernel_sigreturn + 0x0)
0x365eb70: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xecb70
0x366027d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xee27d
(OutputDevice::DrawRect(Rectangle
const&) + 0xc5)
0x367d794: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10b794
0x367fe70: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10de70
0x367fed5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10ded5
(OutputDevice::Erase() + 0x59)
0x3680944: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10e944
0x3680db0: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x10edb0
(VirtualDevice::VirtualDevice(uns
igned short) + 0x4e)
0x877d292: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x72d292
(XDashList::CreateBitmapForUI(lon
g, unsigned char) + 0x50)
0x83809af: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x3309af
(LineLB::Fill(XDashList const*) +
 0x51)
0x842c8e0: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x3dc8e0
0x8432fde: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x3e2fde
(SvxLineStyleToolBoxControl::Upda
te(SfxPoolItem const*) + 0x62)
0x8433245: /usr/lib/openoffice.org2.0/program/libsvx680li.so + 0x3e3245
(SvxLineStyleToolBoxControl::Stat
eChanged(unsigned short, unsigned short, SfxPoolItem const*) + 0xcf)
0x441d37c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1cc37c
(SfxToolBoxControl::statusChanged
(com::sun::star::frame::FeatureStateEvent const&) + 0x536)
0x43ed90c: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19c90c
0x43ee158: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19d158
0x489e63b: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x1d763b
(svt::ToolboxController::bindList
ener() + 0x317)
0x489e7c0: /usr/lib/openoffice.org2.0/program/libsvt680li.so + 0x1d77c0
(svt::ToolboxController::update()
 + 0x70)
0x3bed6f1: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1096f1
0x3bed790: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x109790
0x3bed7d4: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1097d4
0x35f4300: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x82300
0x35ffdce: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8ddce
(Timer::Timeout() + 0x10)
0x3600148: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e148
0x2b5ae51: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3ee51
0x2b5ae3c: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3ee3c
(SalData::Timeout() const
+ 0x24)
0xe519f0: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x189f0
0x2e22fe6: /usr/lib/libglib-2.0.so.0 + 0x24fe6
0x2e214ce: /usr/lib/libglib-2.0.so.0 + 0x234ce (g_main_context_dispatch + 0x1dc)
0x2e244d6: /usr/lib/libglib-2.0.so.0 + 0x264d6
0x2e249b8: /usr/lib/libglib-2.0.so.0 + 0x269b8 (g_main_context_iteration + 0x66)
0xe51bcf: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x18bcf
0x2b61afa: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45afa
(X11SalInstance::Yield(uns
igned char) + 0x28)
0x35fa594: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88594
(Application::Yield() + 0x48)
0x35fa5ca: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x885ca
(Application::Execute() + 0x26)
0x387bc73: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x21c73
(desktop::Desktop::Main() + 0x15ab)
0x35ff99f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8d99f
0x35ffa4f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8da4f (SVMain()
+ 0x29)
0x3876ad7: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cad7 (sal_main
+ 0x57)
0x3876b23: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1cb23 (main + 0x27)
0xb79d5f: /lib/libc.so.6 + 0x14d5f (__libc_start_main + 0xdf)
0x80484c5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4c5


Version-Release number of selected component (if applicable):
2.0.0-3.2.1
Comment 1 Caolan McNamara 2005-10-27 04:38:22 EDT
I'm not able to reproduce when copying things from one simple impress document
to another under GNOME :-(

a) What's your environment, gnome or kde ?
b) does it happen on *every* cut and paste from one impress to another, or
randomly ?
c) is there a sample document which when you select something in it and paste
that into a new impress document you *always* get a crash, if so can you attach
it here for reproduction of the problem
Comment 2 Orion Poplawski 2005-10-27 12:45:52 EDT
a) KDE.
b) Unfortunately, no.  I'll attach two presentations.  The users is basically
copying images/slides from one to the other.  Resizing images.  Selecting and
resizing text.  You know, doing work :-).  Fairly quickly (~10mins) of working
it will crash, which is making it impossible to do her work.
Comment 3 Orion Poplawski 2005-10-27 12:48:36 EDT
Created attachment 120471 [details]
source presentation
Comment 4 Orion Poplawski 2005-10-27 12:49:53 EDT
Created attachment 120472 [details]
target presentation
Comment 5 Caolan McNamara 2005-10-27 13:56:03 EDT
it's probably the KDE klipper that breaks OOo
Comment 6 Orion Poplawski 2005-10-27 14:00:17 EDT
Whose fault is that (OOo or klipper)?

Is removing klipper from the KDE panel enough to deactivate it?  That way we
could test with it not running.
Comment 7 Caolan McNamara 2005-10-27 14:08:57 EDT
Well if I'm right then its OOo fault that it crashes, but try removing klipper
from the panel and see if there's *any* improvement. 

It might be the case that klipper is taking snapshots of selected items at
occasions and under circumstances which a user wouldn't, and so triggered never
tested parts of the cut and paste code.
Comment 8 Orion Poplawski 2005-10-31 15:53:27 EST
Well, looks like stopping klipper has fixed the issue for us, so that looks like
to place to look.  I'll let you know if we see any similar crashes in the future
with it disabled.
Comment 9 Orion Poplawski 2005-10-31 22:03:42 EST
Well, one more crash, though it might be something different:

Yes, I managed to crash ooffice with 
klipper disabled once here.  I opened the ppt file and used the scroll 
bar to scan down to the last slide before it was done loading and 
clicked on it, and the program crashed.  Seemed like I moved too fast 
for it or something...

But it does look like it is more stable without klipper.
Comment 10 Caolan McNamara 2005-11-01 04:51:00 EST
http://www.openoffice.org/issues/show_bug.cgi?id=51738.

The good news is that the klipper problem is known, the bad news is that the
klipper fix for OOo was already applied in the fedora OOo :-(
Comment 11 Caolan McNamara 2005-11-01 08:13:40 EST
I'll give the new updated upstream patch for this a go
Comment 12 Caolan McNamara 2005-12-05 04:20:08 EST
::DrawRect crash was http://gcc.gnu.org/bugzilla/show_bug.cgi?id=25199

Note You need to log in before you can comment on or make changes to this bug.