Bug 171847 - pup gets "assertion failed"
pup gets "assertion failed"
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Depends On:
  Show dependency treegraph
Reported: 2005-10-26 19:08 EDT by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-04 21:17:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-10-26 19:08:04 EDT
Description of problem:

I tried to use pup on few packages from extras which could use an update.
It basically worked but it spit the following:

/usr/share/pup/pup/pup.py:691: GtkWarning: gtk_progress_set_percentage:
assertion `percentage >= 0 && percentage <= 1.0' failed
/usr/share/pup/pup/pup.py:680: GtkWarning: gtk_progress_set_percentage:
assertion `percentage >= 0 && percentage <= 1.0' failed
  self.pbar.set_fraction(self.current / self.total)

The first was at the end of "Downloading Packages" progress bar and
the second one at the very beginning of "Updating Packages".  Smells like
a possible rounding is not taken into account.  Luckily these failed
assertions do not cause exceptions and pup progresses without problems.

Version-Release number of selected component (if applicable):

How reproducible:
Don't know
Comment 1 Jeremy Katz 2006-01-04 21:17:24 EST
I haven't seen this recently.  Reopen if you're still seeing it.
Comment 2 David Lawrence 2006-06-27 21:35:44 EDT
Moving component to pirut. Sorry for the spam.
Comment 3 David Timms 2007-06-18 06:04:29 EDT
I have seen this today. There were about 30 updates available for F7, and this
failed, so started pup from command line, unselected the rest and selected just
cpuspeed. I think it spouted this during the download.
# pup
Loading "installonlyn" plugin
/usr/lib/python2.5/site-packages/pirut/Progress.py:162: GtkWarning:
gtk_progress_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' failed
The updated downloaded and applied successfully.
Would you rather a fresh bug since the module references is now different ?

Note You need to log in before you can comment on or make changes to this bug.