Bug 1718542 - [3.11] Random outages with egressIP
Summary: [3.11] Random outages with egressIP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.11.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.11.z
Assignee: Dan Winship
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On: 1717639
Blocks: 1728342
TreeView+ depends on / blocked
 
Reported: 2019-06-08 12:52 UTC by Dan Winship
Modified: 2019-07-09 17:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: If a pod using an egress IP tries to contact an external host that is not responding, the egress IP monitoring code may mistakenly interpret that as meaning that the node hosting the egress IP is not responding. Consequence: High-availability egress IPs might get switched from one node to another spuriously. Fix: The monitoring code now distinguishes the case of "egress node not responding" from "final destination not responding" Result: High-availability egress IPs will not be switched between nodes unnecessarily.
Clone Of: 1717639
: 1728342 (view as bug list)
Environment:
Last Closed: 2019-07-09 17:58:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23069 'None' 'closed' 'Bug 1718542: Fix egress monitoring for some rare corner cases.' 2019-12-05 15:28:25 UTC
Red Hat Product Errata RHBA-2019:1605 None None None 2019-06-26 09:08:20 UTC

Comment 3 Sean Burke 2019-06-25 17:22:27 UTC
Adding case 02411660 as it looks like they have hit a similar issue

Comment 5 errata-xmlrpc 2019-06-26 09:08:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1605

Comment 9 zhaozhanqi 2019-07-02 10:24:12 UTC
Ravi Trivedi yeah, if they can provide the details commands, that's more better. since I cannot reproduce this issue on 3.11.117 using the above steps. thanks.

Comment 17 Dan Winship 2019-07-08 13:47:07 UTC
This fix wasn't in 3.11.117; it was committed just after that version was tagged. So it didn't make the latest errata. I'm not sure how it ended up being listed as fixed there. (It will be in the next errata.)

Comment 18 shiyang.wang 2019-07-09 17:57:50 UTC
close this one in favor of https://bugzilla.redhat.com/show_bug.cgi?id=1728342


Note You need to log in before you can comment on or make changes to this bug.