Bug 171855 - can't create degraded raid 4
can't create degraded raid 4
Status: CLOSED DUPLICATE of bug 171862
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-26 23:29 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-27 02:18:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-10-26 23:29:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
Attempting to create a degraded raid 4 array produces the following output:

# mdadm -C /dev/md31 -l 4 -n 3 /dev/loop0 /dev/loop1 missing
mdadm: RUN_ARRAY failed: Input/output error

(It's not about the use of loop devices; I've actually run into this with actual hard disk partitions.)

Sure enough, the last syscall that mdadm issues to the kernel fails with -EIO, but I can't tell whether that's because the kernel is in error, or if mdadm is passing incorrect parameters to the kernel.  Doing the very same operation with -l 5 works, FWIW.

On the Fedora development tree, the raid components have already got their raid superblocks written out (or so it seems to me), so a subsequent assemble brings up the degraded raid successfully.  However, on a fully-updated FC4 box, I have no such luck: the superblocks there don't match each other, so nothing happens.

Version-Release number of selected component (if applicable):
mdadm-1.11.0-4.fc4 kernel-2.6.13-1.1622_FC5

How reproducible:
Always

Steps to Reproduce:
1.mdadm -C -l 4 -n 3 /dev/loop{0,1} missing

Actual Results:  -EIO in the last ioctl, the one that, replacing -l4 with -l5, immediately precedes the write() stating that the array was brought up successfully.

Expected Results:  It would be nice if this worked.

Additional info:
Comment 1 Alexandre Oliva 2005-10-27 02:18:30 EDT

*** This bug has been marked as a duplicate of 171862 ***

Note You need to log in before you can comment on or make changes to this bug.