Bug 1718569 - Plymouth doesn't echo LUKS keypresses or show spinner with AMDGPU+LUKS
Summary: Plymouth doesn't echo LUKS keypresses or show spinner with AMDGPU+LUKS
Keywords:
Status: CLOSED DUPLICATE of bug 1490490
Alias: None
Product: Fedora
Classification: Fedora
Component: plymouth
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-08 17:07 UTC by fednuc
Modified: 2019-06-12 08:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-12 08:36:02 UTC
Type: Bug


Attachments (Terms of Use)

Description fednuc 2019-06-08 17:07:43 UTC
Same as https://bugzilla.redhat.com/show_bug.cgi?id=1490490, but I can't re-open it.

Currently boots fine* otherwise, just with a stuck empty LUKS text field for the Plymouth-ed part of boot.

With the radeon driver, this doesn't happen, but radeon has other problems with my hardware making it unusable (corruption on RHS with DCI 4K display, R390X).

Fully updated system, kernel 5.1.6-300.

* More or less - there's a separate GDM bug requiring a GDM service restart for it to load when using AMDGPU, but that seems unrelated.

Comment 1 Hans de Goede 2019-06-12 08:36:02 UTC
There are multiple bugs open about the bullets not being rendered with the amdgpu driver, I'm going to consolidate these into 1 bug. What really needs to happen here is that someone opens a bug with the upstream amdgpu developers so that they can fix this.

Note that you can still make your system boot by blindly typing in the disk password and then hitting enter.

I will add instructions for filing a bug upstream to bug 1490490 which is the original / first filed bug for this.

*** This bug has been marked as a duplicate of bug 1490490 ***


Note You need to log in before you can comment on or make changes to this bug.