Bug 171861 - /etc/profile contains syntax error when using non-bash shell
/etc/profile contains syntax error when using non-bash shell
Status: CLOSED DUPLICATE of bug 160731
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 01:16 EDT by Andy Barclay
Modified: 2014-03-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-27 13:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Barclay 2005-10-27 01:16:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
If an account uses /bin/ksh as the shell, logins throw a syntax error on line 17 of /etc/profile.

To solve this problem, the $EUID on line 17 should be quoted like the following:

if [ "$EUID" = 0 ]

Version-Release number of selected component (if applicable):
setup-2.5.44-1.1

How reproducible:
Always

Steps to Reproduce:
1. Create account with /bin/ksh as the shell
2. Login
3.
  

Actual Results:  
/etc/profile[17]: [: argument expected

Expected Results:  should not have received this error

Additional info:
Comment 1 Bill Nottingham 2005-10-27 13:16:38 EDT

*** This bug has been marked as a duplicate of 160731 ***

Note You need to log in before you can comment on or make changes to this bug.