Bug 1718622 - Red Hat subscription showing during installation process
Summary: Red Hat subscription showing during installation process
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: subscription-manager
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Snyder
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-09 11:46 UTC by Artem
Modified: 2019-06-24 01:00 UTC (History)
13 users (show)

Fixed In Version: subscription-manager-1.25.9-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-22 01:03:29 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (184.93 KB, image/png)
2019-06-09 11:46 UTC, Artem
no flags Details
screenshot2 (72.19 KB, image/png)
2019-06-09 11:47 UTC, Artem
no flags Details

Description Artem 2019-06-09 11:46:25 UTC
Created attachment 1578768 [details]
screenshot

Description of problem:
  When installing non Workstation spin Red Hat subscription showing during installation process. See screenshots.

How reproducible:
  Try installing Xfce respin https://dl.fedoraproject.org/pub/alt/live-respins/F30-XFCE-x86_64-LIVE-20190605.iso

Actual results:
  You will see Red Hat subscription manager.

Expected results:
  You should not see Red Hat subscription manager.

Comment 1 Artem 2019-06-09 11:47:00 UTC
Created attachment 1578769 [details]
screenshot2

Comment 2 Vendula Poncova 2019-06-11 11:46:12 UTC
From subscription-manager.spec:

%if (0%{?fedora} >= 24 || 0%{?rhel} >= 8)
Supplements: initial-setup-gui
%endif

The Anaconda addon com_redhat_subscription_manager is installed, because the package subscription-manager-initial-setup-addon supplements the package initial-setup-gui. The package initial-setup-gui is mandatory for most of the *-desktop groups, so it gets on the live media for all non-gnome desktop environments. The addon shouldn't be installed on the live media by default. Please, fix your spec file. Reassigning.

Comment 3 Adam Williamson 2019-06-17 23:06:38 UTC
We already figured this out and I fixed it a couple of weeks back:

https://github.com/candlepin/subscription-manager/pull/2108

it just didn't make it into Fedora package builds yet. Christopher has now built it, I'll send out an update for F30 (as it seems he forgot to do that).

Comment 4 Fedora Update System 2019-06-17 23:09:23 UTC
FEDORA-2019-31ec284168 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-31ec284168

Comment 5 Ben Williams 2019-06-17 23:23:11 UTC
subscription-manager was pulled in to resolve the updated isos unable to install so updated lives could be released (that was the first f30 respin which even with the subscription-manager had 1.2G of updates.

Comment 6 Fedora Update System 2019-06-18 01:38:21 UTC
subscription-manager-1.25.9-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-31ec284168

Comment 7 Fedora Update System 2019-06-22 01:03:29 UTC
subscription-manager-1.25.9-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 lostmoonofsaturn 2019-06-23 12:19:10 UTC
Installed 6 June Fedora 30 Cinnamon respin. After updating, these rpm's are present:

python3-subscription-manager-rhsm-1.25.9-1.fc30.x86_64
dnf-plugin-subscription-manager-1.25.9-1.fc30.x86_64
subscription-manager-rhsm-certificates-1.25.9-1.fc30.x86_64
subscription-manager-initial-setup-addon-1.25.9-1.fc30.x86_64
subscription-manager-1.25.9-1.fc30.x86_64



However, this is still displayed  on a "dnf update ...":

Updating Subscription Management repositories.
Unable to read consumer identity
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

Comment 9 Adam Williamson 2019-06-23 23:03:59 UTC
Yes, we didn't change anything on update. If you installed from a respin which included the subscription-manager stuff, it will stay there until you remove it manually. Feel free to just uninstall those packages.


Note You need to log in before you can comment on or make changes to this bug.