Bug 171866 - Search in "report bug" broken (expects special keywords)
Search in "report bug" broken (expects special keywords)
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 05:14 EDT by Craig Ringer
Modified: 2013-06-23 23:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 11:14:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Craig Ringer 2005-10-27 05:14:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The search field provided to users in the "report bug" form on bugzilla.redhat.com is missing a handler for the return key. If the user enters some search terms and presses return, the search will fail with the error: "Unknown Keyword" . If they click "search", the search completes fine (in a new window - grr - and middle click doesn't work).

The full error with the suggested example search (which is evidently well aged, being a search for "netscape crash java" sans quotes) is:

"Unknown Keyword
"netscape crash java is not a known keyword. The legal keyword names are listed here.
"Please press Back and try again."

The front page search is just fine, it only seems to be the search in the "new bug" form. Perhaps the "new bug" form should also use onSubmit= instead of onClick= ?

The sample search, by the way, finds a bug so prehistoric that it looks like it should be in a museum.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in to bugzilla
2. Visit https://bugzilla.redhat.com/bugzilla/easy_enter_bug.cgi
3. Type some search terms into the search form
4. Press <return> or <enter> to submit the search
  

Actual Results:  Bugzilla complains that the keywords provided were invalid.

Expected Results:  A page loading with the bugzilla search results.

Additional info:

Firefox 1.0.7, FC4
Comment 1 David Timms 2006-01-23 11:44:20 EST
I concur. It seems the backend is attempting to look in the keyword field within
the database rather than in the summary. (or the summary text needs to be
changed to keyword). Hence, when user enters non-legit keywords the search
always fails.

Pretty important to fix this as this is the way in generating a bug report, and
if search fails to find bugs that should have been shown, there is likely to be
duplicates entered.
Comment 2 David Timms 2006-01-23 12:26:52 EST
Looks like the page is not causing form submission generated by enter to go through:
function SearchForBugs( words, searchRadio )

This has another side affect: if no search term is entered, then a search begun
by the enter key, it takes a couple of minutes of 5 step standby.gif scrolling
through, before I cancelled the web page load. Hopefully it's not doing bad
things to the bz db server (dos-ish).
Comment 3 David Lawrence 2008-09-16 12:53:54 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Note You need to log in before you can comment on or make changes to this bug.